freeswitch: fix a compile error
[openwrt/svn-archive/archive.git] / libs / opal / Makefile
index 1897ce6173a26394f06cec5e1d0e1effe9e3a52d..e9df445f4fd0533aa6b5cedd63d81bf648a1fd1c 100644 (file)
@@ -4,23 +4,22 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: Makefile 8274 2007-07-31 11:22:44Z nbd $
 
 include $(TOPDIR)/rules.mk
 
-PKG_NAME:=opal-snapshot
-PKG_VERSION:=18818
+PKG_NAME:=opal
+PKG_VERSION:=3.2.1
 PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=ftp://peternixon.net/pub/voxgratia
-PKG_MD5SUM:=121b77a82f9a4eb289e2351d588185e9
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-src.tar.bz2
+PKG_SOURCE_URL:=@SF/opalvoip
+PKG_MD5SUM:=405ba3b03ec706b6e6f873de340937e2
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)_$(PKG_VERSION)
 
 # Set location of ptlib (Which needs to have been built already)
-export PWLIBDIR=$(BUILD_DIR)/ptlib-snapshot
-export PTLIBDIR=$(BUILD_DIR)/ptlib-snapshot
+export PTLIBDIR=$(BUILD_DIR)/ptlib
+export PTLIBPLUGINDIR=$(BUILD_DIR)/ptlib/plugins/ptlib/
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -36,9 +35,10 @@ define Package/libopal/description
        Open Phone Abstraction Library, implementation of the ITU H.323
        teleconferencing protocol, and successor of the openh323 library. It
        supports not only the H.323 protocol but also SIP and IAX2.
-
 endef
 
+TARGET_CFLAGS += $(FPIC)
+
 CONFIGURE_ARGS += \
        --enable-audio \
        --disable-video \
@@ -50,7 +50,8 @@ CONFIGURE_ARGS += \
        --disable-h460 \
        --disable-ivr \
        --disable-rfc4175 \
-       --disable-versioncheck
+       --disable-versioncheck \
+       --enable-localgsm
 
 CONFIGURE_VARS += \
        CXXFLAGS="$(TARGET_CFLAGS) -fno-builtin -fno-rtti" \
@@ -61,11 +62,7 @@ MAKE_FLAGS += \
        optnoshared
 
 define Build/InstallDev
-       ln -sf $(PKG_NAME)-$(PKG_VERSION) $(BUILD_DIR)/$(PKG_NAME)
-endef
-
-define Build/UninstallDev
-       rm -rf $(BUILD_DIR)/$(PKG_NAME)
+       ln -sf $(PKG_NAME)_$(PKG_VERSION) $(BUILD_DIR)/$(PKG_NAME)
 endef
 
 $(eval $(call BuildPackage,libopal))