[package] php5: add missing dependency on libsqlite3/libpthread (#7224)
[openwrt/svn-archive/archive.git] / libs / opencdk / Makefile
index 4271cf19ebde34412a2cd287007be6faac5732dc..0d7d71d1f546cf59f3350882536cb4a66d449200 100644 (file)
@@ -1,24 +1,20 @@
 #
-# Copyright (C) 2006, 2007 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=opencdk
 PKG_VERSION:=0.6.6
-PKG_RELEASE:=1
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=ftp://ftp.gnutls.org/pub/gnutls/opencdk/ \
-       ftp://ftp.gnupg.org/gcrypt/alpha/gnutls/opencdk/ \
-       http://www.mirrors.wiretapped.net/security/network-security/gnutls/opencdk/ \
-       ftp://ftp.mirrors.wiretapped.net/pub/security/network-security/gnutls/opencdk/ \
-       http://josefsson.org/gnutls/releases/opencdk/
+PKG_SOURCE_URL:=http://josefsson.org/gnutls/releases/opencdk/
 PKG_MD5SUM:=813d62d7afe7b2c2d8f3df0a6c9d9331
+PKG_FIXUP:=libtool
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -65,14 +61,14 @@ define Build/InstallDev
                $(1)/usr/include/
 
        $(INSTALL_DIR) $(1)/usr/lib
-       $(INSTALL_DATA) \
+       $(CP) \
                $(PKG_INSTALL_DIR)/usr/lib/libopencdk.{la,so*} \
                $(1)/usr/lib/
 endef
 
 define Package/libopencdk/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(INSTALL_DATA) \
+       $(CP) \
                $(PKG_INSTALL_DIR)/usr/lib/libopencdk.so.* \
                $(1)/usr/lib/
 endef