remove host tools from packages/libs/libtool
[openwrt/svn-archive/archive.git] / libs / openldap / Makefile
index 602e166f1069f0beb851d2f62bc248309ec67771..06c526d8e53455c3721651edaff2b7abb1c7099d 100644 (file)
@@ -18,7 +18,6 @@ PKG_SOURCE_URL:=ftp://ftp.openldap.org/pub/OpenLDAP/openldap-release/ \
        ftp://ftp.nl.uu.net/pub/unix/db/openldap/openldap-release/ \
        ftp://ftp.plig.org/pub/OpenLDAP/openldap-release/
 PKG_MD5SUM:=6c4c72a1336aa45b463e738034c078d6
-PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
@@ -27,9 +26,6 @@ include $(INCLUDE_DIR)/package.mk
 
 define Package/openldap/Default
   TITLE:=LDAP implementation
-  DESCRIPTION:=\
-    OpenLDAP Software is an open source implementation of the \\\
-    Lightweight Directory Access Protocol (LDAP).
   URL:=http://www.openldap.org/
 endef
 
@@ -39,9 +35,13 @@ define Package/libopenldap
   CATEGORY:=Libraries
   DEPENDS:=+libopenssl +libsasl2
   TITLE+= (libraries)
-  DESCRIPTION+=\\\
-    \\\
-    This package contains the shared LDAP client libraries, needed by other programs.
+endef
+
+define Package/libopenldap/description
+=
+       OpenLDAP Software is an open source implementation of the 
+       Lightweight Directory Access Protocol (LDAP).   
+       This package contains the shared LDAP client libraries, needed by other programs.
 endef
 
 define Package/libopenldap/conffiles
@@ -54,9 +54,13 @@ define Package/openldap-utils
   CATEGORY:=Utilities
   DEPENDS:=+libopenldap
   TITLE+= (utilities)
-  DESCRIPTION+=\\\
-    \\\
-    This package contains client programs required to access LDAP servers.
+endef
+
+define Package/openldap-utils/description
+=
+       OpenLDAP Software is an open source implementation of the 
+       Lightweight Directory Access Protocol (LDAP).   
+       This package contains client programs required to access LDAP servers.
 endef
 
 CONFIGURE_ARGS += \
@@ -108,7 +112,7 @@ endef
        
 define Package/openldap-utils/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/ldap* $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/ldap* $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,libopenldap))