Update tinyproxy to 1.6.4 (#4007)
[openwrt/svn-archive/archive.git] / libs / postgresql / Makefile
index c31a8b11325b68e20fe83d4fad0d87abcc055534..aa13984505ced38306a8f2cea8af405240fb9ae0 100644 (file)
@@ -9,10 +9,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=postgresql
-PKG_VERSION:=8.3.0
-PKG_RELEASE:=2
+PKG_VERSION:=8.3.3
+PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=\
        http://ftp7.us.postgresql.org/pub/postgresql/source/v$(PKG_VERSION) \
@@ -20,12 +19,10 @@ PKG_SOURCE_URL:=\
        http://ftp9.us.postgresql.org/pub/postgresql/source/v$(PKG_VERSION) \
        http://ftp.be.postgresql.org/postgresql/source/v$(PKG_VERSION) \
        ftp://ftp-archives.postgresql.org/pub/source/v$(PKG_VERSION)
-PKG_MD5SUM:=53d6816eac7442f9bc8103439ebee22e
+PKG_MD5SUM:=0ae4bd9620e84d3e08dcf923808d14d0
 
 PKG_BUILD_DEPENDS:=libnotimpl
 
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
 include $(INCLUDE_DIR)/package.mk
 
 define Package/libpq
@@ -155,6 +152,7 @@ define Build/Configure
                        --without-tk \
                        --with-zlib="yes" \
                        --enable-depend \
+                       $(if $(CONFIG_TARGET_avr32),--disable-spinlocks) \
        );
        $(SED) 's@ECPG = ../../preproc/ecpg@ECPG = ../../preproc/ecpg.host@' $(PKG_BUILD_DIR)/src/interfaces/ecpg/test/Makefile.regress
        $(SED) 's@\./zic -d@./zic.host -d@' $(PKG_BUILD_DIR)/src/timezone/Makefile
@@ -162,6 +160,8 @@ define Build/Configure
        #$(SED) 's@US/Eastern@America/New_York@' $(PKG_BUILD_DIR)/src/timezone/Makefile
 endef
 
+TARGET_CFLAGS += $(FPIC)
+
 define Build/Compile
        $(MAKE) -C "$(PKG_BUILD_DIR)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \