fixed bind-lib dependency, from #2514
[openwrt/svn-archive/archive.git] / libs / postgresql / patches / 200-ranlib.patch
index 7029b099548afa0c099284a3a5ea5444e6793723..ef7d08a8fee503e366b81351fbffddae1c8cdf97 100644 (file)
@@ -1,10 +1,12 @@
---- postgresql.old/src/port/Makefile   Sun Oct 15 00:09:57 2006
-+++ postgresql.dev/src/port/Makefile   Sun Oct 15 00:10:05 2006
-@@ -21,6 +21,7 @@
+Index: postgresql-8.2.5/src/port/Makefile
+===================================================================
+--- postgresql-8.2.5.orig/src/port/Makefile    2007-09-20 10:18:17.000000000 -0500
++++ postgresql-8.2.5/src/port/Makefile 2007-09-20 10:18:17.000000000 -0500
+@@ -43,6 +43,7 @@
  
  libpgport.a: $(LIBOBJS)
        $(AR) $(AROPT) $@ $^
 +      $(RANLIB) libpgport.a
  
  thread.o: thread.c
-       $(CC) $(CFLAGS) $(CPPFLAGS) $(THREAD_CPPFLAGS) -c $<
+       $(CC) $(CFLAGS) $(CPPFLAGS) $(PTHREAD_CFLAGS) -c $<