Merge pull request #4853 from StevenHessing/noddos
[feed/packages.git] / libs / protobuf-c / Makefile
index 49aa9f468cca6cae232c9dee201650b0c2411daa..334d7d969e5cf3562ca419744be582e27cf8b74a 100644 (file)
@@ -8,16 +8,18 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libprotobuf-c
-PKG_VERSION:=v1.0.1
+PKG_VERSION:=v1.2.1
 PKG_RELEASE:=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_MIRROR_HASH:=2ebe48454fe454d118cf952655a24477c4bed892cee7ae085dc56d05ac711a8a
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE_URL:=git://github.com/protobuf-c/protobuf-c.git
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_VERSION:=$(PKG_VERSION)
 
 PKG_INSTALL:=1
+PKG_FIXUP:=autoreconf
 
 PKG_LICENSE:=BSD-2c
 
@@ -44,11 +46,6 @@ CONFIGURE_ARGS += \
        --enable-static \
        --disable-protoc
 
-define Build/Configure
-       cd $(PKG_BUILD_DIR) && ./autogen.sh
-       $(call Build/Configure/Default)
-endef
-
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include/
        $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/