[packages] sane-backends: Update to v1.0.20 (closes #5662)
[openwrt/svn-archive/archive.git] / libs / pwlib / Makefile
index 8e0b99415fc95a86a79ecbce8073892cf5705639..36c4ae6ebb46403910c322f2335456c1491a8125 100644 (file)
@@ -1,16 +1,15 @@
 # 
-# Copyright (C) 2006-2007 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pwlib
 PKG_VERSION:=1.11.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=ftp://peternixon.net/pub/voxgratia
@@ -33,6 +32,8 @@ define Package/pwlib/description
  System.
 endef
 
+TARGET_CFLAGS += $(FPIC)
+
 CONFIGURE_ARGS += \
        --enable-minsize \
        --enable-openh323 \
@@ -49,7 +50,6 @@ CONFIGURE_ARGS += \
        --disable-ftp \
        --enable-http \
        --disable-httpsvc \
-       --disable-ipv6 \
        --disable-jabber \
        --disable-openldap \
        --disable-openssl \
@@ -78,7 +78,7 @@ CONFIGURE_ARGS += \
        --disable-xmlrpc \
 
 CONFIGURE_VARS += \
-       CXXFLAGS="$(TARGET_CFLAGS) -fno-builtin -fno-rtti" \
+       STDCXXFLAGS="$(TARGET_CFLAGS) -fno-builtin" \
 
 MAKE_FLAGS += optnoshared