[package] update libelf to 0.8.11 (#5393)
[openwrt/svn-archive/archive.git] / libs / pwlib / Makefile
index 066abed08bff9b49f2a16372eee70eb39f10fa08..e181201a3f64cf723077c3ded45bed1309d2c23a 100644 (file)
@@ -1,10 +1,9 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -23,17 +22,18 @@ include $(INCLUDE_DIR)/package.mk
 define Package/pwlib
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=+libpthread +uclibcxx
   TITLE:=Portable Windows library
   URL:=http://www.voxgratia.org/
 endef
 
 define Package/pwlib/description
-       PWLib is a moderately large class library that was created as a
-       method to produce applications that run on both Microsoft
      Windows and the X Window System.
+ PWLib is a moderately large class library that was created as a method to 
+ produce applications that run on both Microsoft Windows and the X Window 
+ System.
 endef
 
+TARGET_CFLAGS += $(FPIC)
+
 CONFIGURE_ARGS += \
        --enable-minsize \
        --enable-openh323 \
@@ -76,19 +76,16 @@ CONFIGURE_ARGS += \
        --disable-video \
        --disable-vxml \
        --disable-wavfile \
-       --disable-xmlrpc
+       --disable-xmlrpc \
 
 CONFIGURE_VARS += \
-       CXXFLAGS="$(TARGET_CFLAGS) -fno-builtin -fno-rtti"
+       STDCXXFLAGS="$(TARGET_CFLAGS) -fno-builtin" \
 
 MAKE_FLAGS += optnoshared
 
 define Build/InstallDev
        ln -sf $(PKG_NAME)-$(PKG_VERSION) $(BUILD_DIR)/$(PKG_NAME)
-endef
-
-define Build/UninstallDev
-       rm -rf $(BUILD_DIR)/$(PKG_NAME)
+       $(SED) 's|//\(#include <ptlib/sound.h>\)|\1|' $(PKG_BUILD_DIR)/include/ptlib.h
 endef
 
 $(eval $(call BuildPackage,pwlib))