packages/re: update to 0.3.0 (thanks to Alfred E. Heggestad)
[openwrt/svn-archive/archive.git] / libs / re / Makefile
index 13c0f2713ba801a6ba1a63aa9ac8abed92272b13..9c20d0f41164ab5cd8a00f9804a40aa140052215 100644 (file)
@@ -1,33 +1,31 @@
-#
-# Makefile
-#
+# 
+# Copyright (C) 2010-2011 OpenWrt.org
 # Copyright (C) 2010 Alfred E. Heggestad
 #
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=re
-PKG_VERSION:=0.2.0
+PKG_VERSION:=0.3.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.creytiv.com/pub
-PKG_MD5SUM:=0aa00762fbee7694b9e5844675f5c57d
+PKG_MD5SUM:=1529ea90b141591504b30ac8d7c2af0e
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/libre
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=+libopenssl +libpthread @BROKEN
+  DEPENDS:=+libopenssl +libpthread
   TITLE:=Generic library for real-time communications with async IO support
   URL:=http://www.creytiv.com/
 endef
 
-define Package/libre/description
-       Generic library for real-time communications with async IO support.
-endef
-
 TARGET_CFLAGS += $(FPIC)
 
 define Build/Compile
@@ -40,6 +38,8 @@ define Build/Compile
                SYSROOT="$(TOOLCHAIN_DIR)" \
                SYSROOT_ALT="$(STAGING_DIR)/usr" \
                RELEASE=1 \
+               CROSS_COMPILE="$(TARGET_CROSS)" \
+               OS=linux \
                all install
 endef
 
@@ -49,19 +49,12 @@ define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/re $(1)/usr/include/
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libre.{a,so*} $(1)/usr/lib/
-endef
-
-define Build/UninstallDev
-       rm -rf \
-               $(STAGING_DIR)/usr/share/re \
-               $(STAGING_DIR)/usr/include/re \
-               $(STAGING_DIR)/usr/lib/libre.{a,so*}
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libre.{a,so} $(1)/usr/lib/
 endef
 
 define Package/libre/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libre.so* $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libre.so $(1)/usr/lib/
 endef
 
 $(eval $(call BuildPackage,libre))