build,travis: fix gpg verification warning
[feed/packages.git] / libs / speex / Makefile
index 48522a5eb7bcd773e666d85db26a56931a0f8c9d..01538ebe1804c3f58754d0bb768ebf5b5331576d 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2017 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,14 +8,15 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=speex
-PKG_VERSION:=1.2rc1
+PKG_VERSION:=1.2.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://downloads.us.xiph.org/releases/speex/
-PKG_MD5SUM:=c4438b22c08e5811ff10e2b06ee9b9ae
+PKG_HASH:=eaae8af0ac742dc7d542c9439ac72f1f385ce838392dc849cae4536af9210094
 
 PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,14 +28,6 @@ define Package/libspeex
   MAINTAINER:=Peter Wagner <tripolar@gmx.at>
 endef
 
-define Package/libspeexdsp
-  SECTION:=libs
-  CATEGORY:=Libraries
-  TITLE:=Open source speech compression codec library output to DSP
-  URL:=http://www.speex.org/
-  MAINTAINER:=Peter Wagner <tripolar@gmx.at>
-endef
-
 define Package/libspeex/description
        Open source patent-free speech compression codec library.
        Speex is an Open Source/Free Software patent-free audio compression
@@ -47,48 +40,13 @@ define Package/libspeex/description
        This package contains the shared codec library, needed by other programs.
 endef
 
-TARGET_CFLAGS += $(FPIC)
-
-define Package/libspeexdsp/description
-       Open source patent-free speech compression codec library.
-       Speex is an Open Source/Free Software patent-free audio compression
-       format designed for speech. The Speex Project aims to lower the
-       barrier of entry for voice applications by providing a free
-       alternative to expensive proprietary speech codecs. Moreover, Speex
-       is well-adapted to Internet applications and provides useful features
-       that are not present in most other codecs.
-
-       This package contains the shared dsp library, needed by other programs.
-endef
-
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --enable-shared \
-               --enable-static \
-               --enable-fixed-point \
-               --disable-oggtest \
-               --disable-float-api \
-               --disable-vbr \
-               --with-ogg=$(STAGING_DIR)/usr \
-       )
-endef
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               bin_PROGRAMS="" \
-               all install
-endef
-
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/speex $(1)/usr/include/
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libspeex.{a,so*} $(1)/usr/lib/
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libspeexdsp.{a,so*} $(1)/usr/lib/
        $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/speex.pc $(1)/usr/lib/pkgconfig/
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/speexdsp.pc $(1)/usr/lib/pkgconfig/
 endef
 
 define Package/libspeex/install
@@ -96,10 +54,12 @@ define Package/libspeex/install
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libspeex.so.* $(1)/usr/lib/
 endef
 
-define Package/libspeexdsp/install
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libspeexdsp.so.* $(1)/usr/lib/
-endef
+TARGET_CFLAGS += $(FPIC)
+
+CONFIGURE_ARGS += \
+       --enable-shared \
+       --enable-static \
+       --disable-binaries \
+       $(if $(CONFIG_SOFT_FLOAT),--enable-fixed-point --disable-float-api --disable-vbr)
 
 $(eval $(call BuildPackage,libspeex))
-$(eval $(call BuildPackage,libspeexdsp))