[packages] avahi: disable the dbus support on brcm-2.4, it does not build
[openwrt/svn-archive/archive.git] / libs / speex / Makefile
index f75507aeb15a52b4afb97c0040db8b09406f0efb..57fa983c2c5028262c138ad7c6f3384d68b70259 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006-2009 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=speex
-PKG_VERSION:=1.2beta3.2
+PKG_VERSION:=1.2rc1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://downloads.us.xiph.org/releases/speex/
-PKG_MD5SUM:=b47396952c5fdd54b6468316c3bd339f
+PKG_MD5SUM:=c4438b22c08e5811ff10e2b06ee9b9ae
+
+PKG_FIXUP:=libtool
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -64,8 +66,8 @@ define Build/Configure
                --enable-fixed-point \
                --disable-oggtest \
                --disable-float-api \
-               --disable-vbr, \
-               OGG_CFLAGS="" \
+               --disable-vbr \
+               --with-ogg=$(STAGING_DIR)/usr \
        )
 endef