Add libnfsidmap
[openwrt/svn-archive/archive.git] / libs / speex / Makefile
index 271cb704c93eec3fb892d8886f5f02c053aa2544..ddbc00fd49cd793a22c15a28293ed2d03ea67fb0 100644 (file)
@@ -9,16 +9,17 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=speex
-PKG_VERSION:=1.1.8
+PKG_VERSION:=1.2beta1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://us.speex.org/download 
-PKG_MD5SUM:=734892c8ca5e7e835828048a1289a0cc
+PKG_SOURCE_URL:=http://downloads.us.xiph.org/releases/speex/
+PKG_MD5SUM:=aac2e4ba42122b885c787ea280acb3d9
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_BUILD_DEPENDS:=libnotimpl
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -39,10 +40,13 @@ define Package/libspeex
   URL:=http://www.speex.org/
 endef
 
+TARGET_LDFLAGS:=$(TARGET_LDFLAGS) -lnotimpl
+
 define Build/Configure
        $(call Build/Configure/Default, \
                --enable-shared \
                --enable-static \
+               --enable-fixed-point \
                --disable-oggtest \
        )
 endef