[PATCH] fix uclib bug in jamvm
[openwrt/svn-archive/archive.git] / libs / speex / Makefile
index 62668681dc8b4189dc6efd3d3fccbc42e5969a61..f75507aeb15a52b4afb97c0040db8b09406f0efb 100644 (file)
@@ -1,24 +1,19 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=speex
-PKG_VERSION:=1.1.8
+PKG_VERSION:=1.2beta3.2
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://us.speex.org/download 
-PKG_MD5SUM:=734892c8ca5e7e835828048a1289a0cc
-PKG_CAT:=zcat
-
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_SOURCE_URL:=http://downloads.us.xiph.org/releases/speex/
+PKG_MD5SUM:=b47396952c5fdd54b6468316c3bd339f
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,80 +21,82 @@ define Package/libspeex
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=Open source speech compression codec library
-  DESCRIPTION:=Open source patent-free speech compression codec library.\\\
-    Speex is an Open Source/Free Software patent-free audio compression \\\
-    format designed for speech. The Speex Project aims to lower the \\\
-    barrier of entry for voice applications by providing a free \\\
-    alternative to expensive proprietary speech codecs. Moreover, Speex \\\
-    is well-adapted to Internet applications and provides useful features \\\
-    that are not present in most other codecs.\\\
-    \\\
-    This package contains the shared codec library, needed by other programs.
   URL:=http://www.speex.org/
 endef
 
+define Package/libspeexdsp
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE:=Open source speech compression codec library output to DSP
+  URL:=http://www.speex.org/
+endef
+
+define Package/libspeex/description
+       Open source patent-free speech compression codec library.
+       Speex is an Open Source/Free Software patent-free audio compression 
+       format designed for speech. The Speex Project aims to lower the 
+       barrier of entry for voice applications by providing a free 
+       alternative to expensive proprietary speech codecs. Moreover, Speex 
+       is well-adapted to Internet applications and provides useful features 
+       that are not present in most other codecs.
+
+       This package contains the shared codec library, needed by other programs.
+endef
+
+TARGET_CFLAGS += $(FPIC)
+
+define Package/libspeexdsp/description
+       Open source patent-free speech compression codec library.
+       Speex is an Open Source/Free Software patent-free audio compression 
+       format designed for speech. The Speex Project aims to lower the 
+       barrier of entry for voice applications by providing a free 
+       alternative to expensive proprietary speech codecs. Moreover, Speex 
+       is well-adapted to Internet applications and provides useful features 
+       that are not present in most other codecs.
+
+       This package contains the shared dsp library, needed by other programs.
+endef
+
 define Build/Configure
-       (cd $(PKG_BUILD_DIR); rm -f config.cache; \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(strip $(TARGET_CFLAGS))" \
-               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
-               ./configure \
-                       --target=$(GNU_TARGET_NAME) \
-                       --host=$(GNU_TARGET_NAME) \
-                       --build=$(GNU_HOST_NAME) \
-                       --program-prefix="" \
-                       --program-suffix="" \
-                       --prefix=/usr \
-                       --exec-prefix=/usr \
-                       --bindir=/usr/bin \
-                       --datadir=/usr/share \
-                       --includedir=/usr/include \
-                       --infodir=/usr/share/info \
-                       --libdir=/usr/lib \
-                       --libexecdir=/usr/lib \
-                       --localstatedir=/var \
-                       --mandir=/usr/share/man \
-                       --sbindir=/usr/sbin \
-                       --sysconfdir=/etc \
-                       $(DISABLE_LARGEFILE) \
-                       $(DISABLE_NLS) \
-                       --enable-shared \
-                       --enable-static \
-                       --disable-rpath \
-                       --with-gnu-ld \
-                       --disable-oggtest \
-       );
+       $(call Build/Configure/Default, \
+               --enable-shared \
+               --enable-static \
+               --enable-fixed-point \
+               --disable-oggtest \
+               --disable-float-api \
+               --disable-vbr, \
+               OGG_CFLAGS="" \
+       )
 endef
 
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                bin_PROGRAMS="" \
                all install
 endef
 
-define Package/libspeex/install
-       install -d -m0755 $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libspeex.so.* $(1)/usr/lib/
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/speex $(1)/usr/include/
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libspeex.{a,so*} $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libspeexdsp.{a,so*} $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/speex.pc $(1)/usr/lib/pkgconfig/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/speexdsp.pc $(1)/usr/lib/pkgconfig/
 endef
 
-define Build/InstallDev
-       mkdir -p $(STAGING_DIR)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/speex $(STAGING_DIR)/usr/include/
-       mkdir -p $(STAGING_DIR)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libspeex.{a,so*} $(STAGING_DIR)/usr/lib/
-       mkdir -p $(STAGING_DIR)/usr/lib/pkgconfig
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/speex.pc $(STAGING_DIR)/usr/lib/pkgconfig/
+define Package/libspeex/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libspeex.so.* $(1)/usr/lib/
 endef
 
-define Build/UninstallDev
-       rm -rf \
-               $(STAGING_DIR)/usr/include/speex \
-               $(STAGING_DIR)/usr/lib/libspeex.{a,so*} \
-               $(STAGING_DIR)/usr/lib/pkgconfig/speex.pc
+define Package/libspeexdsp/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libspeexdsp.so.* $(1)/usr/lib/
 endef
 
 $(eval $(call BuildPackage,libspeex))
+$(eval $(call BuildPackage,libspeexdsp))
+