nghttp3: fix pkgconfig file
[feed/packages.git] / libs / spice-protocol / Makefile
index d8c6fc189c74fbe63ea7d86b7bcce35bd538ae49..213de0d0613f059d99d0b993f0ac61c310b6cbd6 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2019 Yousong Zhou <yszhou4tech@gmail.com>
+# Copyright (C) 2019-2020 Yousong Zhou <yszhou4tech@gmail.com>
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,24 +8,24 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=spice-protocol
-PKG_VERSION:=0.14.0
+PKG_VERSION:=0.14.4
 PKG_RELEASE:=1
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://www.spice-space.org/download/releases
-PKG_HASH:=b6a4aa1ca32668790b45a494bbd000e9d05797b391d5a5d4b91adf1118216eac
+PKG_HASH:=04ffba610d9fd441cfc47dfaa135d70096e60b1046d2119d8db2f8ea0d17d912
 PKG_LICENSE:=BSD-3-Clause
 PKG_LICENSE_FILES:=COPYING
-PKG_INSTALL:=1
 PKG_MAINTAINER:=Yousong Zhou <yszhou4tech@gmail.com>
 
 include $(INCLUDE_DIR)/package.mk
-
+include $(INCLUDE_DIR)/meson.mk
 
 define Package/spice-protocol
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=SPICE - headers defining protocols
   URL:=https://www.spice-space.org/index.html
+  BUILDONLY:=1
 endef
 
 define Build/InstallDev