iptraf: remove the useless call to the "size" command, which breaks on some platforms
[openwrt/svn-archive/archive.git] / libs / sqlite2 / Makefile
index 3af3e7d728d2bf2ea864dc8b3586e5cd049138dc..037632ae06370d110050232bb00aad333a8ed212 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -22,6 +22,7 @@ PKG_BUILD_DEPENDS:=libncurses libreadline
 include $(INCLUDE_DIR)/package.mk
 
 define Package/sqlite2/Default
+  SUBMENU:=database
   TITLE:=SQLite (v2.x) database engine
   URL:=http://www.sqlite.org/
 endef
@@ -67,8 +68,8 @@ define Build/Configure
                config_BUILD_CFLAGS="-O2" \
                config_TARGET_CC="$(TARGET_CC)" \
                config_TARGET_CFLAGS="$(TARGET_CFLAGS)" \
-               config_TARGET_READLINE_INC="-I$(STAGING_DIR)/usr/include" \
-               config_TARGET_READLINE_LIBS="-L$(STAGING_DIR)/usr/lib -lreadline -lncurses" \
+               config_TARGET_READLINE_INC="$(TARGET_CPPFLAGS)" \
+               config_TARGET_READLINE_LIBS="$(TARGET_LDFLAGS) -lreadline -lncurses" \
                config_TARGET_TCL_INC="-DNO_TCL=1" \
        )
 endef