Revert previous changeset, as it could break libtool fixups
[openwrt/svn-archive/archive.git] / libs / taglib / Makefile
index eeb70b4fa8e93c8a5509bfe8cc4767993b317e5e..f62376be29413a8592bd2c55fb2e082f57619b9f 100644 (file)
@@ -21,11 +21,13 @@ include $(INCLUDE_DIR)/package.mk
 define Package/taglib
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:= +uclibcxx +zlib
+  DEPENDS:= +uclibcxx +zlib @!TARGET_avr32
   TITLE:=Audio output library
   URL:=http://developer.kde.org/~wheeler/taglib.html
 endef
 
+TARGET_CFLAGS += $(FPIC)
+
 CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \
@@ -52,12 +54,6 @@ define Build/InstallDev
        $(CP) $(PKG_INSTALL_DIR)/usr/include/taglib/* $(1)/usr/include/taglib/
 endef
 
-define Build/UninstallDev
-       rm -rf  $(STAGING_DIR)/usr/bin/taglib-config \
-               $(STAGING_DIR)/usr/include/taglib \
-               $(STAGING_DIR)/usr/lib/libtag.{a,so*}
-endef
-
 define Package/taglib/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libtag.so.* $(1)/usr/lib/