[package] update fftw3 to 3.2.1 (#5391)
[openwrt/svn-archive/archive.git] / libs / wxbase / Makefile
index 930a815c57a9608b17c30c48af641b71431645d7..49edaa3e87aa5654b274343d31d28b043fe92dad 100644 (file)
@@ -1,16 +1,15 @@
 # 
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=wxbase
 PKG_VERSION:=2.8.7
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=wxGTK-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/wxwindows
@@ -25,7 +24,7 @@ define Package/libwxbase
   CATEGORY:=Libraries
   TITLE:=Cross-platform C++ framework
   URL:=http://www.wxwidgets.org/
-  DEPENDS:=+libexpat +uclibcxx +zlib
+  DEPENDS:=+libexpat +libstdcpp +zlib
 endef
 
 define Package/libwxbase/description
@@ -36,6 +35,7 @@ define Package/libwxbase/description
  etc.) allowing you to write portable programs easily.
 endef
 
+TARGET_CFLAGS += $(FPIC)
 
 # XXX: aMule *needs* the following configure options to be enabled:
 #      --enable-intl
@@ -103,9 +103,6 @@ CONFIGURE_ARGS+= \
        --without-sdl-prefix \
        --without-cppunit-prefix \
 
-CONFIGURE_VARS+= \
-       CXX="g++-uc+std" \
-
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \