alfred: update to version 2024.0
[feed/routing.git] / luci-app-cjdns / Makefile
index b42feb4e1722158c2d1378bd2d28f66fa0f820ed..0b6485a1264a5f18d1972928a3a503ec4490b63a 100644 (file)
@@ -18,7 +18,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=luci-app-cjdns
 PKG_VERSION:=1.3
-PKG_RELEASE:=7
+PKG_RELEASE:=9
 
 PKG_MAINTAINER:=William Fleurant <meshnet@protonmail.com>
 PKG_LICENSE:=GPL-3.0-or-later
@@ -31,7 +31,7 @@ define Package/luci-app-cjdns
        SUBMENU:=3. Applications
        TITLE:=Encrypted near-zero-conf mesh routing protocol
        URL:=https://github.com/cjdelisle/cjdns
-       DEPENDS:=+cjdns +luci-base
+       DEPENDS:=+cjdns +luci-compat +luci-base
 endef
 
 define Package/luci-app-cjdns/description
@@ -45,8 +45,9 @@ define Build/Compile
 endef
 
 define Package/luci-app-cjdns/install
-       $(INSTALL_DIR) $(1)/usr/lib/lua/luci
+       $(INSTALL_DIR) $(1)/usr/lib/lua/luci $(1)/usr/share/rpcd/acl.d
        $(CP) ./luasrc/* $(1)/usr/lib/lua/luci
+       $(CP) ./files/luci-app-cjdns.json $(1)/usr/share/rpcd/acl.d
 endef
 
 $(eval $(call BuildPackage,luci-app-cjdns))