Translated using Weblate (Russian)
[project/luci.git] / luci.mk
diff --git a/luci.mk b/luci.mk
index f8d6e100bd768d429712e24c05ff68e3491679bd..53c5130681cc9d1642075387f4711948f8cae0e2 100644 (file)
--- a/luci.mk
+++ b/luci.mk
@@ -36,6 +36,7 @@ LUCI_LANG.hu=Magyar (Hungarian)
 LUCI_LANG.it=Italiano (Italian)
 LUCI_LANG.ja=日本語 (Japanese)
 LUCI_LANG.ko=한국어 (Korean)
+LUCI_LANG.lt=Lietuvių (Lithuanian)
 LUCI_LANG.mr=Marāṭhī (Marathi)
 LUCI_LANG.ms=Bahasa Melayu (Malay)
 LUCI_LANG.nb_NO=Norsk (Norwegian)
@@ -114,9 +115,8 @@ PKG_SRC_VERSION?=$(if $(DUMP),x,$(strip $(call findrev,1)))
 PKG_GITBRANCH?=$(if $(DUMP),x,$(strip $(shell \
        variant="LuCI"; \
        if git log -1 >/dev/null 2>/dev/null; then \
-               branch=$$(git branch --remote --no-abbrev --contains 2>/dev/null | tail -n1); \
-               branch=$${branch:-$$(git branch --no-abbrev --contains 2>/dev/null)}; \
-               branch=$${branch#? }; branch=$${branch#*/}; \
+               branch=$$(git branch --format='%(refname:strip=3)' --remote --no-abbrev --contains 2>/dev/null | tail -n1); \
+               branch=$${branch:-$$(git branch --format='%(refname:strip=2)' --no-abbrev --contains 2>/dev/null | tail -n1)}; \
                if [ "$$branch" != "master" ]; then \
                        variant="LuCI $${branch:-unknown} branch"; \
                else \