opendkim: use pkgconfig for libbsd
[feed/packages.git] / mail / opendkim / Makefile
index d4c1c2562e4d2f12bb3cf6e9ce5d02472fe8dd02..b25a955a97894ecb7131ef7a7b281449c534f589 100644 (file)
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=opendkim
 PKG_VERSION:=2.10.3
-PKG_RELEASE:=5
+PKG_RELEASE:=6
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/$(PKG_NAME)
@@ -61,14 +61,14 @@ define Package/opendkim-tools/description
   opendkim-genzone, opendkim-testkey and opendkim-testmsg tools.
 endef
 
-TARGET_CFLAGS += $(FPIC)
-
 CONFIGURE_ARGS += \
        --without-db \
        --without-gcov \
        --without-gprof \
        --without-lcov \
-       --with-milter=$(STAGING_DIR)/usr
+       $(if $(CONFIG_USE_GLIBC),,--without-libbsd) \
+       --with-milter=$(STAGING_DIR)/usr \
+       --with-pic
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/lib $(1)/usr/sbin