bc: use @DEBIAN
[feed/packages.git] / mail / postfix / Makefile
index 4b9add1ea1cc6e9c604fdddd9550553e0976aed3..b86fdcb6d7998fa0622422c37d15f71d8d32e3a5 100644 (file)
@@ -8,14 +8,15 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=postfix
-PKG_RELEASE:=1
-PKG_VERSION:=3.5.0
+PKG_VERSION:=3.5.8
+PKG_RELEASE:=3
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:= \
-       https://cdn.postfix.johnriley.me/mirrors/postfix-release/official/ \
+       https://de.postfix.org/ftpmirror/official/ \
        http://ftp.porcupine.org/mirrors/postfix-release/official/
+PKG_HASH:=22582628cf3edc18c5155c9ff44543dd95a9435fb68135d76a99f572cb07456f
 
-PKG_HASH:=22ac929733449a294252ac8deda4b264ff48a997ff3847007291a2ee53ef55cc
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_MAINTAINER:=Denis Shulyaka <Shulyaka@gmail.com>
 PKG_LICENSE:=IPL-1.0
 PKG_LICENSE_FILES:=LICENSE
@@ -44,6 +45,7 @@ define Package/postfix
        postdrop=26:postdrop=26
   URL:=http://www.postfix.org/
   DEPENDS:=+POSTFIX_CDB:tinycdb +POSTFIX_TLS:libopenssl +POSTFIX_SASL:libsasl2 +POSTFIX_LDAP:libopenldap +POSTFIX_DB:libdb47 +POSTFIX_SQLITE:libsqlite3 +POSTFIX_MYSQL:libmysqlclient +POSTFIX_PGSQL:libpq +POSTFIX_EAI:icu +POSTFIX_PCRE:libpcre
+  MENU:=1
 endef
 
 define Package/postfix/description
@@ -51,66 +53,74 @@ define Package/postfix/description
 endef
 
 define Package/postfix/config
-       menu "Select postfix build options"
-               config POSTFIX_TLS
-                       bool "TLS support"
-                       default y
-                       help
-                         Implements TLS support in postfix (using OpenSSL).
-               config POSTFIX_SASL
-                       bool "SASL support"
-                       default y
-                       help
-                         Implements SASL support in postfix (using Cyrus SASL).
-               config POSTFIX_LDAP
-                       bool "LDAP support"
-                       default y
-                       help
-                         Implements LDAP support in postfix (using OpenLDAP).
-               config POSTFIX_DB
-                       bool "BerkeleyDB support"
-                       default n
-                       help
-                         Implements support for btree and hash files using Berkeley DB.
-               config POSTFIX_CDB
-                       bool "CDB support"
-                       default y
-                       help
-                         Implements support for cdb files using tinycdb
-               config POSTFIX_SQLITE
-                       bool "SQLITE support"
-                       default y
-                       help
-                         Implements support for SQLite3 DB
-               config POSTFIX_MYSQL
-                       bool "MYSQL support"
-                       default n
-                       help
-                         Implements support for MySQL
-               config POSTFIX_PGSQL
-                       bool "PostgreSQL support"
-                       default n
-                       help
-                         Implement support for PostgreSQL
-               config POSTFIX_PCRE
-                       bool "PCRE support"
-                       default y
-                       help
-                         Implement support for Perl Compatible Regular Expressions
-               config POSTFIX_EAI
-                       bool "SMTPUTF8 support"
-                       default n
-                       help
-                         Enable Postfix support for Email Address Internationalization
-                         (EAI) as defined in RFC 6531 (SMTPUTF8 extension), RFC 6532
-                         (Internationalized email headers) and RFC 6533
-                         (Internationalized delivery status notifications).
-                         Since version 3.0, Postfix fully supports UTF-8 email
-                         addresses and UTF-8 message header values.
-       endmenu
+       config POSTFIX_TLS
+               depends on PACKAGE_postfix
+               bool "TLS support"
+               default y
+               help
+                       Implements TLS support in postfix (using OpenSSL).
+       config POSTFIX_SASL
+               depends on PACKAGE_postfix
+               bool "SASL support"
+               default y
+               help
+                       Implements SASL support in postfix (using Cyrus SASL).
+       config POSTFIX_LDAP
+               depends on PACKAGE_postfix
+               bool "LDAP support"
+               default y
+               help
+                       Implements LDAP support in postfix (using OpenLDAP).
+       config POSTFIX_DB
+               depends on PACKAGE_postfix
+               bool "BerkeleyDB support"
+               default n
+               help
+                       Implements support for btree and hash files using Berkeley DB.
+       config POSTFIX_CDB
+               depends on PACKAGE_postfix
+               bool "CDB support"
+               default y
+               help
+                       Implements support for cdb files using tinycdb
+       config POSTFIX_SQLITE
+               depends on PACKAGE_postfix
+               bool "SQLITE support"
+               default y
+               help
+                       Implements support for SQLite3 DB
+       config POSTFIX_MYSQL
+               depends on PACKAGE_postfix
+               bool "MYSQL support"
+               default n
+               help
+                       Implements support for MySQL
+       config POSTFIX_PGSQL
+               depends on PACKAGE_postfix
+               bool "PostgreSQL support"
+               default n
+               help
+                       Implement support for PostgreSQL
+       config POSTFIX_PCRE
+               depends on PACKAGE_postfix
+               bool "PCRE support"
+               default y
+               help
+                       Implement support for Perl Compatible Regular Expressions
+       config POSTFIX_EAI
+               depends on PACKAGE_postfix
+               bool "SMTPUTF8 support"
+               default n
+               help
+                       Enable Postfix support for Email Address Internationalization
+                       (EAI) as defined in RFC 6531 (SMTPUTF8 extension), RFC 6532
+                       (Internationalized email headers) and RFC 6533
+                       (Internationalized delivery status notifications).
+                       Since version 3.0, Postfix fully supports UTF-8 email
+                       addresses and UTF-8 message header values.
 endef
 
-CCARGS=-DNO_NIS
+CCARGS=-DNO_NIS -fcommon
 AUXLIBS=-L$(STAGING_DIR)/usr/lib
 
 ifdef CONFIG_POSTFIX_TLS
@@ -178,6 +188,7 @@ else
 endif
 
 CCARGS+=-DDEF_DB_TYPE=\"$(default_database_type)\"
+TARGET_LDFLAGS += $(if $(CONFIG_USE_GLIBC),-lresolv)
 
 # prevent postfix-install from executing postconf at build time
 # by explicitly providing the default values to postfix-install
@@ -215,7 +226,7 @@ endef
 
 define Build/Compile
        # Currently postfix has a bug with Makefiles that CCARGS are not passed to the compiler, so we are copying them to CC as a workaround
-       cd $(PKG_BUILD_DIR); $(MAKE) $(TARGET_CONFIGURE_OPTS) CC='$(TARGET_CC) $(CCARGS)'
+       cd $(PKG_BUILD_DIR); $(MAKE) $(TARGET_CONFIGURE_OPTS) CC='$(TARGET_CC) $(CCARGS) $(TARGET_CFLAGS) $(TARGET_LDFLAGS)'
        $(foreach p, \
                default_database_type config_directory command_directory daemon_directory \
                shlib_directory manpage_directory data_directory queue_directory \