at: bump version
[feed/packages.git] / multimedia / icecast / Makefile
index ea115f3a997307d579e62d902338c166603cfff1..b65c77ef9d62d6474a5a79b0b734ce011694bf89 100644 (file)
@@ -1,6 +1,4 @@
 #
-# Copyright (C) 2006-2011 OpenWrt.org
-#
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
@@ -9,25 +7,27 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=icecast
 PKG_VERSION:=2.4.3
-PKG_RELEASE:=2
-PKG_LICENSE:=GPL-2.0
-PKG_MAINTAINER:=AndrĂ© Gaul <andre@gaul.io>
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://downloads.xiph.org/releases/icecast/
-PKG_MD5SUM:=83d7d34dbe22f0f8fc119d2c9839efc0
+PKG_SOURCE_URL:=https://downloads.xiph.org/releases/icecast/
+PKG_HASH:=c85ca48c765d61007573ee1406a797ae6cb31fb5961a42e7f1c87adb45ddc592
+
+PKG_MAINTAINER:=AndrĂ© Gaul <andre@gaul.io>, \
+               Ted Hess <thess@kitschensync.net>
+
+PKG_LICENSE:=GPL-2.0
+PKG_LICENSE_FILES:=COPYING
 
 PKG_FIXUP:=autoreconf
+PKG_INSTALL:= 1
 
 include $(INCLUDE_DIR)/package.mk
 
-TREMOR_BUILD_DIR=$(PKG_BUILD_DIR)/libvorbisidec-1.2.0-dave
-TREMOR_DIR=$(TREMOR_BUILD_DIR)/ipkg-install/usr
-
 define Package/icecast
   SECTION:=multimedia
   CATEGORY:=Multimedia
-  DEPENDS:=+libcurl +libxml2 +libxslt +libogg +libopenssl
+  DEPENDS:=+libcurl +libxml2 +libxslt +libogg +libvorbisidec
   TITLE:=A streaming media server for Ogg/Vorbis and MP3 audio streams
   USERID:=icecast=87:icecast=87
   URL:=http://www.icecast.org/
@@ -42,39 +42,22 @@ define Package/icecast/description
        interaction.
 endef
 
-define Build/Prepare
-       $(Build/Prepare/Default)
-       $(SUBMAKE) -f libvorbisidec.mk \
-               BUILD_DIR="$(PKG_BUILD_DIR)" \
-               V=99 \
-               prepare
-endef
+CONFIGURE_ARGS+= \
+       --enable-yp \
+       --with-openssl="no" \
+       --with-curl="yes" \
+       --with-curl-config="$(STAGING_DIR)/usr/bin/curl-config" \
+       --with-ogg="$(STAGING_DIR)/usr" \
+       --with-speex="no" \
+       --with-theora="no" \
+       --with-vorbis="$(STAGING_DIR)/usr" \
+       --with-xslt-config="$(STAGING_DIR)/usr/bin/xslt-config"
 
-define Build/Configure
-       $(MAKE) -f libvorbisidec.mk \
-               BUILD_DIR="$(PKG_BUILD_DIR)" \
-               V=99 \
-               compile
-       $(SED) 's,-lvorbis ,$(TREMOR_DIR)/lib/libvorbisidec.a -logg ,g' $(PKG_BUILD_DIR)/configure
-       $(call Build/Configure/Default, \
-               --enable-yp \
-               --with-curl="yes" \
-               --with-curl-config="$(STAGING_DIR)/usr/bin/curl-config" \
-               --with-ogg="$(STAGING_DIR)/usr" \
-               --with-speex="no" \
-               --with-theora="no" \
-               --with-vorbis="$(TREMOR_DIR)" \
-               --with-xslt-config="$(STAGING_DIR)/usr/bin/xslt-config" \
-               , \
-               CPPFLAGS="-I$(TREMOR_DIR)/include -I$(STAGING_DIR)/usr/include/libxml2 $(TARGET_CPPFLAGS)" \
-       )
-endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               INCLUDES="-I$(PKG_BUILD_DIR)/src -I$(TREMOR_DIR)/include" \
-               all install
+# Manually edit configure in case both vorbis and tremor host packages are installed
+define Build/Configure
+       $(SED) 's,-lvorbis -lm,-lvorbisidec -logg ,g' $(PKG_BUILD_DIR)/configure
+       $(call Build/Configure/Default)
 endef
 
 define Package/icecast/install