[packages] digitemp: Add ds9097u support (#8778)
[openwrt/svn-archive/archive.git] / multimedia / motion / Makefile
index a29d90a3cc61811856c5731ba7ab77c724c7d9e1..867333ffebb5a3296c02bb177b5f4919c8614f32 100644 (file)
@@ -1,55 +1,49 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2008-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=motion
-PKG_VERSION:=3.2.6
+PKG_VERSION:=3.2.11.1
 PKG_RELEASE:=1
-PKG_MD5SUM:=71e6bd13fcca70372e9b7c7806d62b30
 
-PKG_SOURCE_URL:=@SF/motion
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
+PKG_SOURCE_URL:=http://www.lavrsen.dk/sources/motion-daily \
+               @SF/motion
+PKG_MD5SUM:=4e729f129d8f9b9abaed5121c3cd0037
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/motion
   SECTION:=multimedia
   CATEGORY:=Multimedia
-  DEPENDS:=+libjpeg
+  DEPENDS:=+libjpeg +libpthread
   TITLE:=webcam motion sensing and logging
-  DESCRIPTION:=Motion is a software motion detector
   URL:=http://www.lavrsen.dk/twiki/bin/view/Motion/WebHome
 endef
 
-define Build/Configure
-$(call Build/Configure/Default,--without-ffmpeg \
-                       --without-jpeg-mmx \
-                       --without-mysql \
-                       --without-pgsql \
-)
+define Package/motion/conffiles
+/etc/motion.conf
 endef
 
-define Build/Compile   
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
+CONFIGURE_ARGS+= \
+       --without-ffmpeg \
+       --without-jpeg-mmx \
+       --without-mysql \
+       --without-pgsql \
+
+define Package/motion/install
+       $(INSTALL_DIR) $(1)/etc
+       $(CP) $(PKG_INSTALL_DIR)/etc/motion-dist.conf $(1)/etc/motion.conf
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/motion $(1)/usr/bin/
 
-define Package/motion/install  
-       install -d -m0755 $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/motion $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,motion))