fix a dependency problem
[openwrt/svn-archive/archive.git] / multimedia / motion / Makefile
index a29d90a3cc61811856c5731ba7ab77c724c7d9e1..eb45d1f2ff5d11fdfd311564359632445c9b39c2 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,13 +9,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=motion
-PKG_VERSION:=3.2.6
+PKG_VERSION:=3.2.9
 PKG_RELEASE:=1
-PKG_MD5SUM:=71e6bd13fcca70372e9b7c7806d62b30
 
-PKG_SOURCE_URL:=@SF/motion
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
+PKG_SOURCE_URL:=http://www.lavrsen.dk/sources/motion-daily \
+               @SF/motion
+PKG_MD5SUM:=6003011b126c9b17e23e085e7fba6536
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
@@ -27,29 +27,34 @@ define Package/motion
   CATEGORY:=Multimedia
   DEPENDS:=+libjpeg
   TITLE:=webcam motion sensing and logging
-  DESCRIPTION:=Motion is a software motion detector
   URL:=http://www.lavrsen.dk/twiki/bin/view/Motion/WebHome
 endef
 
+define Package/motion/conffiles
+/etc/motion.conf
+endef
+
 define Build/Configure
-$(call Build/Configure/Default,--without-ffmpeg \
-                       --without-jpeg-mmx \
-                       --without-mysql \
-                       --without-pgsql \
-)
+       $(call Build/Configure/Default, \
+               --without-ffmpeg \
+               --without-jpeg-mmx \
+               --without-mysql \
+               --without-pgsql \
+       )
 endef
 
-define Build/Compile   
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
+define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
 endef
 
-define Package/motion/install  
-       install -d -m0755 $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/motion $(1)/usr/bin/
+define Package/motion/install
+       $(INSTALL_DIR) $(1)/etc
+       $(CP) $(PKG_INSTALL_DIR)/etc/motion-dist.conf $(1)/etc/motion.conf
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/motion $(1)/usr/bin/
+
 endef
 
 $(eval $(call BuildPackage,motion))