[nodogsplash] fixing syntax errors in the init script
[openwrt/svn-archive/archive.git] / multimedia / uvc-streamer / Makefile
index de8dfee515b96df9995c6170bd9a05dcae665d4d..6dc4f10357854f234254c2fdd8114347d0c321f6 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -25,11 +24,13 @@ define Package/uvc-streamer
   CATEGORY:=Utilities
   TITLE:=Linux-UVC streaming applicaton
   DEPENDS:=@LINUX_2_6 +libpthread
-  DESCRIPTION:=\
-  This package contains a streaming daemon for Linux-UVC based webcams
   URL:=http://www.naaa.de/uvc_streamer
 endef
 
+define Package/uvc-streamer/description
+       This package contains a streaming daemon for Linux-UVC based webcams
+endef
+
 MAKE_FLAGS += \
        -C $(PKG_BUILD_DIR) \
        CFLAGS="$(TARGET_CFLAGS)" \
@@ -38,7 +39,11 @@ MAKE_FLAGS += \
 
 define Package/uvc-streamer/install
        $(INSTALL_DIR) $(1)/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/uvc_stream $(1)/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/uvc_stream $(1)/sbin/uvc_streamer
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_DATA) ./files/$(PKG_NAME).config $(1)/etc/config/$(PKG_NAME)
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/$(PKG_NAME).init $(1)/etc/init.d/$(PKG_NAME)
 endef
 
 $(eval $(call BuildPackage,uvc-streamer))