added libboost (serialization only for now)
[openwrt/svn-archive/archive.git] / net / amule / Makefile
old mode 100755 (executable)
new mode 100644 (file)
index 02aa011..7a0d720
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,11 +10,11 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=aMule
 PKG_VERSION:=2.1.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/amule
-PKG_MD5SUM:=
+PKG_MD5SUM:=0aafdd159edb8ad5f0064da87998b47d
 
 PKG_BUILD_DEPENDS:=libgd
 
@@ -65,13 +65,6 @@ CONFIGURE_ARGS+= \
        --without-libintl-prefix \
        --without-x \
 
-CONFIGURE_VARS+= \
-       CXX="g++-uc+std" \
-
-define Build/Configure
-       $(call Build/Configure/Default,)
-endef
-
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                HOSTCC="$(HOSTCC)" \
@@ -81,7 +74,7 @@ endef
 
 define Package/amule/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/amule{cmd,d,web} $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/amule{cmd,d,web} $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/usr/share
        $(CP) $(PKG_INSTALL_DIR)/usr/share/amule $(1)/usr/share/
 endef