[pacakges] ngircd: Add berlios mirror (thanks Jonas Gorski)
[openwrt/svn-archive/archive.git] / net / apcupsd / Makefile
index 76fb621dc446edf3e3ae9d6f2935ea2c2909634e..9ce3cd8d4aa393dc220eddf14d92e934a4f19cd9 100644 (file)
@@ -4,25 +4,23 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: Makefile 6500 2007-03-04 04:19:46Z pavlov $
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=apcupsd
-PKG_VERSION:=3.14.2
+PKG_VERSION:=3.14.7
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/apcupsd
-PKG_MD5SUM:=fd8785e7607d20cefa68dc20e44eebc4
-PKG_CAT:=zcat
+PKG_MD5SUM:=bb2f8e4fc6b2f5d7b3e236eb57b81640
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/apcupsd
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=+libpthread
+  DEPENDS:=+libpthread +libusb
   TITLE:=UPS control software
   URL:=http://www.apcupsd.org/
 endef
@@ -32,6 +30,8 @@ define Build/Configure
        $(call Build/Configure/Default, \
                --with-distname=unknown \
                --sysconfdir=/etc/apcupsd \
+               --enable-usb \
+               --without-x \
        )
 endef