Merge pull request #4853 from StevenHessing/noddos
[feed/packages.git] / net / apcupsd / Makefile
index 65b318e44d1a73944977e430bfaf457d181940c0..da18a0e165a4e6672146cc1d2a6eb3f0d2806444 100644 (file)
@@ -8,8 +8,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=apcupsd
-PKG_VERSION:=3.14.13
-PKG_RELEASE:=3
+PKG_VERSION:=3.14.14
+PKG_RELEASE:=1
 
 PKG_MAINTAINER:=Othmar Truniger <github@truniger.ch>
 PKG_LICENSE:=GPL-2.0
@@ -17,7 +17,7 @@ PKG_LICENSE_FILES:=COPYING
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/apcupsd
-PKG_MD5SUM:=c291d9d3923b4d9c0e600b755ad4f489
+PKG_HASH:=db7748559b6b4c3784f9856561ef6ac6199ef7bd019b3edcd7e0a647bf8f9867
 
 PKG_BUILD_DEPENDS:=libgd
 
@@ -26,7 +26,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/apcupsd
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libpthread
+  DEPENDS:=+libpthread +libusb-compat
   TITLE:=UPS control software
   URL:=http://www.apcupsd.org/
 endef
@@ -46,6 +46,7 @@ define Build/Configure
                --sysconfdir=/etc/apcupsd \
                --enable-cgi \
                --enable-usb \
+               --enable-modbus-usb \
                --without-x \
        )
 endef
@@ -78,13 +79,11 @@ endef
 
 define Package/apcupsd-cgi/install
        $(INSTALL_DIR) $(1)/www/cgi-bin/apcupsd
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/etc/apcupsd/multimon.cgi $(1)/www/cgi-bin/apcupsd
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/etc/apcupsd/upsfstats.cgi $(1)/www/cgi-bin/apcupsd
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/etc/apcupsd/upsimage.cgi $(1)/www/cgi-bin/apcupsd
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/etc/apcupsd/upsstats.cgi $(1)/www/cgi-bin/apcupsd
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/etc/apcupsd/*.cgi $(1)/www/cgi-bin/apcupsd
        $(INSTALL_DIR) $(1)/etc/apcupsd
        $(INSTALL_CONF) ./files/apcupsd.css $(1)/etc/apcupsd/
        $(INSTALL_CONF) ./files/hosts.conf $(1)/etc/apcupsd/
+       $(INSTALL_CONF) ./files/multimon.conf $(1)/etc/apcupsd/
 endef
 
 define Package/apcupsd/conffiles
@@ -100,6 +99,7 @@ endef
 define Package/apcupsd-cgi/conffiles
 /etc/apcupsd/apcupsd.css
 /etc/apcupsd/hosts.conf
+/etc/apcupsd/multimon.conf
 endef
 
 $(eval $(call BuildPackage,apcupsd))