[packages] transmission: fix typo
[openwrt/svn-archive/archive.git] / net / appweb / Makefile
index bae954d1d0e58b115828643cadde20a518dfeedd..d52e7aebd95310d0721d5bcbbe0c4c955abc3b98 100644 (file)
@@ -1,12 +1,12 @@
 #
-#      Makefile for the Appweb Web Server
+# Copyright (C) 2009-2010 OpenWrt.org
+# Copyright (C) 2009 Embedthis Software
 #
-#      Copyright (C) 2009 Embedthis Software
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
 #
-#      This software is licensed under the GPLv2. Commercial and other licenses
-#   are available from http://www.embedthis.com.
+# Commercial and other licenses are available from http://www.embedthis.com/.
 #
-#      $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -14,43 +14,44 @@ PKG_NAME:=appweb
 PKG_RELEASE:=1
 
 #
-#      Build 3.0B.3
+#      Build stable
 #
-PKG_SOURCE_URL:=http://www.appwebserver.org/software/
-PKG_VERSION:=3.0B.2-3
-PKG_MD5SUM:=b54a99d388a5588a9af33aa1c6354e06
+PKG_VERSION:=3.2.2-1
 PKG_SOURCE:=$(PKG_NAME)-src-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://www.appwebserver.org/software/
+PKG_MD5SUM:=060d43c8194fa6a119cada966fc807a7
+
 #
 #      Build the latest snapshot from the default trunk
 #
-#      PKG_SOURCE:=tip.tar.gz
-#      PKG_SOURCE_URL:= http://hg.embedthis.com/appweb/archive/
-#      PKG_VERSION:=default
-#      PKG_MD5SUM:=
+#PKG_VERSION:=default
+#PKG_SOURCE:=tip.tar.gz
+#PKG_SOURCE_URL:= http://hg.embedthis.com/appweb/archive/
+#PKG_MD5SUM:=
 
 include $(INCLUDE_DIR)/package.mk
 
-CONFIGURE_ARGS += -q --defaults=release --shared --tune=size --without-php \
-       --without-ssl --disable-angel --disable-samples --disable-access-log \
-       --disable-complete-native --disable-complete-cross --webdir=/www \
-       --logdir=/var/log --port=8000 --sslPort=8443 --config=flat
-
 define Package/appweb
   SECTION:=net
   CATEGORY:=Network
+  SUBMENU:=Web Servers/Proxies
   TITLE:=Appweb Web Server
-  VERSION:=$(PKG_VERSION)
   URL:=http://www.appwebserver.org/
+  DEPENDS:=@!avr32 +libpthread
 endef
 
 define Package/appweb/description
      Appweb is a powerful, compact embedded web server designed for dynamic web
      applications.
+ Appweb is a powerful, compact embedded web server designed for dynamic web
+ applications.
 endef
 
+CONFIGURE_ARGS += \
+       -q --defaults=release --shared --tune=size --without-php \
+       --without-ssl --disable-angel --disable-samples --disable-access-log \
+       --disable-complete-native --disable-complete-cross --webdir=/www \
+       --logdir=/var/log --port=8000 --sslPort=8443 --config=flat
+
 define Build/Prepare
-       rm -rf $(PKG_BUILD_DIR)
-       mkdir -p $(PKG_BUILD_DIR)
        tar xzf "$(DL_DIR)/$(PKG_SOURCE)" --strip-components 1 -C "$(PKG_BUILD_DIR)"
 endef
 
@@ -65,7 +66,7 @@ endef
 define Package/appweb/install
        ( cd $(PKG_BUILD_DIR) ; $(PKG_BUILD_DIR)/build/bin/makeInstall \
                --root=$(1) --install --with-openwrt=1 binary )
+       rm -rf $(1)/var
 endef
 
 $(eval $(call BuildPackage,appweb))
-