[packages] aria2: update to 1.15.1
[openwrt/svn-archive/archive.git] / net / aria2 / Makefile
index 8db2cf7fa313cf4f99db00ff39aedee9627b457e..132a94b1c677743471ce323aa2e81007da0a9bf4 100644 (file)
@@ -7,12 +7,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=aria2
-PKG_VERSION:=1.14.1
+PKG_VERSION:=1.15.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/aria2
-PKG_MD5SUM:=3a23844ab3e1460eb7e6dac9b5dd798c
+PKG_MD5SUM:=a749a1f7cfe03a7518630d2310267c42
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
@@ -20,29 +20,29 @@ include $(INCLUDE_DIR)/package.mk
 define Package/aria2
   SECTION:=net
   CATEGORY:=Network
-  TITLE:=Lightweight download utility
+  SUBMENU:=File Transfer
+  TITLE:=lightweight download utility
   URL:=http://aria2.sourceforge.net/
   DEPENDS:=+libopenssl +zlib +libxml2 +libstdcpp \
        $(INTL_DEPENDS) $(ICONV_DEPENDS)
 endef
 
 define Package/aria2/description
- aria2 is a lightweight multi-protocol & multi-source download utility 
- operated in command-line. It supports HTTP/HTTPS, FTP, BitTorrent and 
- Metalink. aria2 has built-in JSON-RPC and XML-RPC interface. You can 
- manipulate aria2 via these interfaces.
+ aria2 is a lightweight multi-protocol & multi-source command-line download
+ utility
 endef
 
 CONFIGURE_ARGS += \
+       --disable-nls \
        --without-gnutls \
        --without-libnettle \
        --without-libgmp \
        --without-libgcrypt \
-       --with-openssl \
-       --without-sqlite3 \
-       --with-libxml2 \
        --without-libexpat \
        --without-libcares \
+       --without-sqlite3 \
+       --with-openssl \
+       --with-libxml2 \
        --with-libz
 
 CONFIGURE_VARS += \
@@ -50,8 +50,8 @@ CONFIGURE_VARS += \
        ZLIB_LIBS="-L$(STAGING_DIR)/usr/lib"
 
 define Package/aria2/install
-       $(INSTALL_DIR) $(1)/usr/bin/
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/aria2c $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/aria2c $(1)/usr/bin
 endef
 
 $(eval $(call BuildPackage,aria2))