[packages] libusb-1.0: add a workaround for uClibc TFD_NONBLOCK / O_NONBLOCK mismatch...
[openwrt/svn-archive/archive.git] / net / asterisk-1.8.x / Makefile
index d48342cea02b483f2dc960b27fef2252fcbc2910..1903f6a5482c3cd35e4c0c6351636e91797efdb0 100644 (file)
@@ -8,19 +8,19 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=asterisk18
-PKG_VERSION:=1.8.2.3
-PKG_RELEASE:=1
+PKG_VERSION:=1.8.3.2
+PKG_RELEASE:=2
 
 PKG_SOURCE:=asterisk-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://downloads.digium.com/pub/asterisk/releases/
-PKG_MD5SUM:=e394b63dd71c07497620dc12883e0b80
+PKG_MD5SUM:=0bee03f4498a6081146a579b51130633
 
 PKG_BUILD_DIR=$(BUILD_DIR)/asterisk-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/asterisk18/Default
-  SUBMENU:=asterisk18 (Complete Open Source PBX), v1.8.x
+  SUBMENU:=Telephony
   SECTION:=net
   CATEGORY:=Network
   URL:=http://www.asterisk.org/
@@ -37,7 +37,8 @@ endef
 
 define Package/asterisk18
 $(call Package/asterisk18/Default)
-  TITLE:=Complete open source PBX
+  TITLE:=Complete open source PBX, v1.8x
+  MENU:=1
   DEPENDS:= +libopenssl +libncurses +libpopt +libpthread +zlib @!TARGET_avr32
 endef
 
@@ -48,7 +49,7 @@ endef
 define Package/asterisk18-sounds
 $(call Package/asterisk18/Default)
   TITLE:=Sound files
-  DEPENDS:= +asterisk18
+  DEPENDS:= asterisk18
 endef
 
 define Package/asterisk18-sounds/description
@@ -60,7 +61,7 @@ endef
 define Package/asterisk18-voicemail
 $(call Package/asterisk18/Default)
   TITLE:=Voicemail support
-  DEPENDS:= +asterisk18
+  DEPENDS:= asterisk18
 endef
 
 define Package/asterisk18-voicemail/description
@@ -71,7 +72,7 @@ endef
 define Package/asterisk18-app-meetme
 $(call Package/asterisk18/Default)
   TITLE:=conferencing support
-  DEPENDS:= +asterisk18 +dahdi-tools-libtonezone +kmod-dahdi-linux
+  DEPENDS:= asterisk18 +dahdi-tools-libtonezone +kmod-dahdi-linux
 endef
 
 define Package/asterisk18-app-meetme/description
@@ -83,7 +84,7 @@ endef
 define Package/asterisk18-chan-iax2
 $(call Package/asterisk18/Default)
   TITLE:=IAX support
-  DEPENDS:= +asterisk18
+  DEPENDS:= asterisk18 +asterisk18-res-crypto
 endef
 
 define Package/asterisk18-chan-iax2/description
@@ -95,7 +96,7 @@ endef
 define Package/asterisk18-cdr
 $(call Package/asterisk18/Default)
   TITLE:=CDR support
-  DEPENDS:= +asterisk18
+  DEPENDS:= asterisk18
 endef
 
 define Package/asterisk18-cdr/description
@@ -107,7 +108,7 @@ endef
 define Package/asterisk18-res-musiconhold
 $(call Package/asterisk18/Default)
   TITLE:=MOH support
-  DEPENDS:= +asterisk18
+  DEPENDS:= asterisk18
 endef
 
 define Package/asterisk18-res-musiconhold/description
@@ -119,7 +120,7 @@ endef
 define Package/asterisk18-chan-gtalk
 $(call Package/asterisk18/Default)
   TITLE:=GTalk support
-  DEPENDS:= +asterisk18 +libiksemel
+  DEPENDS:= asterisk18 +libiksemel
 endef
 
 define Package/asterisk18-chan-gtalk/description
@@ -131,7 +132,7 @@ endef
 define Package/asterisk18-chan-mobile
 $(call Package/asterisk18/Default)
   TITLE:=Mobile channel support
-  DEPENDS:= +asterisk18 +bluez-libs
+  DEPENDS:= asterisk18 +bluez-libs
 endef
 
 define Package/asterisk18-chan-mobile/description
@@ -142,7 +143,7 @@ endef
 define Package/asterisk18-chan-mgcp
 $(call Package/asterisk18/Default)
   TITLE:=MGCP channel support
-  DEPENDS:= +asterisk18
+  DEPENDS:= asterisk18
 endef
 
 define Package/asterisk18-chan-mgcp/description
@@ -153,7 +154,7 @@ endef
 define Package/asterisk18-curl
 $(call Package/asterisk18/Default)
   TITLE:=CURL support
-  DEPENDS:= +asterisk18 +libcurl
+  DEPENDS:= asterisk18 +libcurl
 endef
 
 define Package/asterisk18-curl/description
@@ -165,7 +166,7 @@ endef
 define Package/asterisk18-mysql
 $(call Package/asterisk18/Default)
   TITLE:=MySQL support
-  DEPENDS:= +asterisk18 +libmysqlclient
+  DEPENDS:= asterisk18 +libmysqlclient
 endef
 
 define Package/asterisk18-mysql/description
@@ -266,12 +267,12 @@ define Build/Compile
        ASTLDFLAGS="$(EXTRA_LDFLAGS)" \
        $(MAKE) -C "$(PKG_BUILD_DIR)" \
                ASTVARLIBDIR="/usr/lib/asterisk" \
+               ASTDATADIR="/usr/lib/asterisk" \
                NOISY_BUILD="1" \
                DEBUG="" \
                OPTIMIZE="" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install samples
-       $(SED) 's|/var/lib/asterisk|/usr/lib/asterisk|g' $(PKG_INSTALL_DIR)/etc/asterisk/musiconhold.conf
 endef
 
 define Build/InstallDev
@@ -321,7 +322,7 @@ endef
 
 define Package/asterisk18-sounds/install
        $(INSTALL_DIR) $(1)/usr/lib/asterisk/sounds/
-       $(CP) $(PKG_INSTALL_DIR)/var/lib/asterisk/sounds/en/* $(1)/usr/lib/asterisk/sounds/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/asterisk/sounds/en/* $(1)/usr/lib/asterisk/sounds/
        rm -f $(1)/usr/lib/asterisk/sounds/vm-*
        rm -f $(1)/usr/lib/asterisk/sounds/conf-*
 endef
@@ -338,7 +339,7 @@ define Package/asterisk18-voicemail/install
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/asterisk/modules/*voicemail.so $(1)/usr/lib/asterisk/modules/
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/asterisk/modules/res_adsi.so $(1)/usr/lib/asterisk/modules/
        $(INSTALL_DIR) $(1)/usr/lib/asterisk/sounds/
-       $(CP) $(PKG_INSTALL_DIR)/var/lib/asterisk/sounds/en/vm-*.gsm $(1)/usr/lib/asterisk/sounds/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/asterisk/sounds/en/vm-*.gsm $(1)/usr/lib/asterisk/sounds/
 endef
 
 define Package/asterisk18-app-meetme/conffiles
@@ -352,7 +353,7 @@ define Package/asterisk18-app-meetme/install
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/asterisk/modules/app_meetme.so $(1)/usr/lib/asterisk/modules/
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/asterisk/modules/chan_dahdi.so $(1)/usr/lib/asterisk/modules/
        $(INSTALL_DIR) $(1)/usr/lib/asterisk/sounds/
-       $(CP) $(PKG_INSTALL_DIR)/var/lib/asterisk/sounds/en/conf-*.gsm $(1)/usr/lib/asterisk/sounds/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/asterisk/sounds/en/conf-*.gsm $(1)/usr/lib/asterisk/sounds/
 endef
 
 define Package/asterisk18-chan-iax2/conffiles
@@ -459,7 +460,7 @@ define Buildasterisk18ModuleTemplate
   define Package/asterisk18-$(subst _,-,$(1))
   $$(call Package/asterisk18/Default)
     TITLE:=$(2) support
-    DEPENDS:= +asterisk18
+    DEPENDS:= asterisk18 $(4)
   endef
 
   define Package/asterisk18-$(subst _,-,$(1))/description
@@ -497,7 +498,7 @@ $(eval $(call Buildasterisk18ModuleTemplate,app_readexten,Extension to variable,
 $(eval $(call Buildasterisk18ModuleTemplate,app_read,Variable read,a trivial application to read a variable))
 $(eval $(call Buildasterisk18ModuleTemplate,app_sayunixtime,Say Unix time,an application to say Unix time))
 $(eval $(call Buildasterisk18ModuleTemplate,app_sms,SMS,SMS support (ETSI ES 201 912 protocol 1)))
-$(eval $(call Buildasterisk18ModuleTemplate,app_stack,Stack applications, stack applications Gosub Return etc.))
+$(eval $(call Buildasterisk18ModuleTemplate,app_stack,Stack applications, stack applications Gosub Return etc., +asterisk18-res-agi))
 $(eval $(call Buildasterisk18ModuleTemplate,app_system,System exec,support for executing system commands))
 $(eval $(call Buildasterisk18ModuleTemplate,app_talkdetect,File playback with audio detect,for file playback with audio detect))
 $(eval $(call Buildasterisk18ModuleTemplate,app_waituntil,Sleep,support sleeping until the given epoch))
@@ -523,6 +524,7 @@ $(eval $(call Buildasterisk18ModuleTemplate,pbx_ael,Asterisk Extension Logic,sup
 $(eval $(call Buildasterisk18ModuleTemplate,res_ael_share,Shareable AEL code,support for shareable AEL code mainly between internal and external modules))
 $(eval $(call Buildasterisk18ModuleTemplate,pbx_spool,Call Spool,outgoing call spool support))
 $(eval $(call Buildasterisk18ModuleTemplate,res_agi,Asterisk Gateway Interface,support for the Asterisk Gateway Interface extension))
+$(eval $(call Buildasterisk18ModuleTemplate,res_crypto,Provide Crypto,Cryptographic Signature capability))
 $(eval $(call Buildasterisk18ModuleTemplate,app_alarmreceiver,Alarm receiver,Central Station Alarm receiver for Ademco Contact ID))
 $(eval $(call Buildasterisk18ModuleTemplate,app_setcallerid,Set callerid,support for setting callerid))
 $(eval $(call Buildasterisk18ModuleTemplate,app_verbose,Verbose logging,Verbose logging application))