asterisk-chan-sccp-b: update revision to 5845
[feed/telephony.git] / net / asterisk-11.x-chan-sccp-b / Makefile
index ba050e88af9ea9d980b69b228c03081d7f2cd6ba..bf75648bf017bf00ff5f026bc82009e601710d10 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2013 OpenWrt.org
+# Copyright (C) 2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,28 +8,31 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=asterisk11-chan-sccp-b
-PKG_REV=4883
-PKG_VERSION:=4.1r$(PKG_REV)
+PKG_REV:=5845
+PKG_VERSION:=v4.2-r$(PKG_REV)
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://svn.code.sf.net/p/chan-sccp-b/code/branches/V4.1
+PKG_SOURCE_URL:=http://svn.code.sf.net/p/chan-sccp-b/code/tags/openwrt
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE_VERSION:=$(PKG_REV)
 PKG_SOURCE_PROTO:=svn
 
 PKG_FIXUP:=autoreconf -fi
 
+PKG_LICENSE:=GPL-1.0
+PKG_LICENSE_FILES:=COPYRIGHT LICENSE
+PKG_MAINTAINER:=Jiri Slachta <slachta@cesnet.cz>
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/asterisk11-chan-sccp-b
   SUBMENU:=Telephony
   SECTION:=net
   CATEGORY:=Network
-  TITLE:=SCCP channel provider for asterisk
+  TITLE:=SCCP channel provider support
   URL:=http://chan-sccp-b.sourceforge.net/
   DEPENDS:=asterisk11 +libltdl
-  MAINTAINER:=Jiri Slachta <slachta@cesnet.cz>
 endef
 
 define Package/asterisk11-chan-sccp-b/description
@@ -54,7 +57,7 @@ endef
 
 define Package/asterisk11-chan-sccp-b/install
        $(INSTALL_DIR) $(1)/etc/asterisk
-       $(CP)  ./files/sccp.openwrt.conf $(1)/etc/asterisk/sccp.conf
+       $(CP) ./files/sccp.openwrt.conf $(1)/etc/asterisk/sccp.conf
        $(INSTALL_DIR) $(1)/usr/lib/asterisk/modules
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/asterisk/modules/chan_sccp.so $(1)/usr/lib/asterisk/modules/
 endef