asterisk-15.x: remove sounds cache
[feed/telephony.git] / net / asterisk-15.x / Makefile
index e5e7183aeb014b7a8776ddfba8c965e984d0c41e..9825de2c02bd5c9076856c0fef97881e28887511 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2017 Jiri Slachta <jiri@slachta.eu>
+# Copyright (C) 2017 - 2018 Jiri Slachta <jiri@slachta.eu>
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=asterisk15
-PKG_VERSION:=15.2.0
+PKG_VERSION:=15.3.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=asterisk-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://downloads.asterisk.org/pub/telephony/asterisk/releases
-PKG_HASH:=5ab2c80e3cb1a933013415d49dbb100e5d2045aeaf926f8eb0ed3b77460a6d83
+PKG_HASH:=f424f89f23b72f267ff9baab82d449bebbbf00c54e54fcd06b8fca13788b012c
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/asterisk-$(PKG_VERSION)
 PKG_BUILD_DEPENDS:=libxml2/host
@@ -37,8 +37,288 @@ MENUSELECT_CATEGORIES:= \
        MENUSELECT_UTILS \
        MENUSELECT_AGIS
 
+MODULES_AVAILABLE:= \
+       app-adsiprog \
+       app-agent-pool \
+       app-alarmreceiver \
+       app-amd \
+       app-authenticate \
+       app-bridgeaddchan \
+       app-bridgewait \
+       app-celgenuserevent \
+       app-chanisavail \
+       app-channelredirect \
+       app-chanspy \
+       app-confbridge \
+       app-controlplayback \
+       app-dahdiras \
+       app-dictate \
+       app-directed-pickup \
+       app-directory \
+       app-disa \
+       app-dumpchan \
+       app-exec \
+       app-externalivr \
+       app-festival \
+       app-flash \
+       app-followme \
+       app-getcpeid \
+       app-ices \
+       app-image \
+       app-ivrdemo \
+       app-milliwatt \
+       app-minivm \
+       app-mixmonitor \
+       app-morsecode \
+       app-mp3 \
+       app-originate \
+       app-page \
+       app-playtones \
+       app-privacy \
+       app-queue \
+       app-read \
+       app-readexten \
+       app-record \
+       app-saycounted \
+       app-sayunixtime \
+       app-senddtmf \
+       app-sendtext \
+       app-skel \
+       app-sms \
+       app-softhangup \
+       app-speech \
+       app-stack \
+       app-stasis \
+       app-statsd \
+       app-stream-echo \
+       app-system \
+       app-talkdetect \
+       app-test \
+       app-transfer \
+       app-url \
+       app-userevent \
+       app-verbose \
+       app-waitforring \
+       app-waitforsilence \
+       app-waituntil \
+       app-while \
+       app-zapateller \
+       bridge-builtin-features \
+       bridge-builtin-interval-features \
+       bridge-holding \
+       bridge-native-rtp \
+       bridge-simple \
+       bridge-softmix \
+       cdr \
+       cdr-csv \
+       cdr-sqlite3 \
+       cel-custom \
+       cel-manager \
+       cel-sqlite3-custom \
+       chan-alsa \
+       chan-bridge-media \
+       chan-console \
+       chan-dahdi \
+       chan-iax2 \
+       chan-mgcp \
+       chan-mobile \
+       chan-motif \
+       chan-ooh323 \
+       chan-oss \
+       chan-phone \
+       chan-rtp \
+       chan-sip \
+       chan-skinny \
+       chan-unistim \
+       codec-a-mu \
+       codec-adpcm \
+       codec-alaw \
+       codec-dahdi \
+       codec-g722 \
+       codec-g726 \
+       codec-gsm \
+       codec-ilbc \
+       codec-lpc10 \
+       codec-resample \
+       codec-speex \
+       codec-ulaw \
+       curl \
+       format-g719 \
+       format-g723 \
+       format-g726 \
+       format-g729 \
+       format-gsm \
+       format-h263 \
+       format-h264 \
+       format-ilbc \
+       format-jpeg \
+       format-mp3 \
+       format-ogg-speex \
+       format-ogg-vorbis \
+       format-pcm \
+       format-siren14 \
+       format-siren7 \
+       format-sln \
+       format-vox \
+       format-wav \
+       format-wav-gsm \
+       func-aes \
+       func-base64 \
+       func-blacklist \
+       func-callcompletion \
+       func-channel \
+       func-config \
+       func-cut \
+       func-db \
+       func-devstate \
+       func-dialgroup \
+       func-dialplan \
+       func-enum \
+       func-env \
+       func-extstate \
+       func-frame-trace \
+       func-global \
+       func-groupcount \
+       func-hangupcause \
+       func-holdintercept \
+       func-iconv \
+       func-jitterbuffer \
+       func-lock \
+       func-math \
+       func-md5 \
+       func-module \
+       func-periodic-hook \
+       func-pitchshift \
+       func-presencestate \
+       func-rand \
+       func-realtime \
+       func-sha1 \
+       func-shell \
+       func-sorcery \
+       func-speex \
+       func-sprintf \
+       func-srv \
+       func-sysinfo \
+       func-talkdetect \
+       func-uri \
+       func-version \
+       func-vmcount \
+       func-volume \
+       odbc \
+       pbx-ael \
+       pbx-dundi \
+       pbx-loopback \
+       pbx-lua \
+       pbx-realtime \
+       pbx-spool \
+       pgsql \
+       pjsip \
+       res-adsi \
+       res-ael-share \
+       res-agi \
+       res-ari \
+       res-ari-applications \
+       res-ari-asterisk \
+       res-ari-bridges \
+       res-ari-channels \
+       res-ari-device-states \
+       res-ari-endpoints \
+       res-ari-events \
+       res-ari-mailboxes \
+       res-ari-model \
+       res-ari-playbacks \
+       res-ari-recordings \
+       res-ari-sounds \
+       res-calendar \
+       res-calendar-caldav \
+       res-calendar-ews \
+       res-calendar-exchange \
+       res-calendar-icalendar \
+       res-chan-stats \
+       res-clialiases \
+       res-clioriginate \
+       res-config-ldap \
+       res-config-mysql \
+       res-config-sqlite3 \
+       res-convert \
+       res-endpoint-stats \
+       res-hep \
+       res-hep-pjsip \
+       res-hep-rtcp \
+       res-fax-spandsp \
+       res-fax \
+       res-format-attr-celt \
+       res-format-attr-g729 \
+       res-format-attr-h263 \
+       res-format-attr-h264 \
+       res-format-attr-ilbc \
+       res-format-attr-opus \
+       res-format-attr-silk \
+       res-format-attr-siren14 \
+       res-format-attr-siren7 \
+       res-format-attr-vp8 \
+       res-http-media-cache \
+       res-http-websocket \
+       res-limit \
+       res-manager-devicestate \
+       res-manager-presencestate \
+       res-monitor \
+       res-musiconhold \
+       res-mutestream \
+       res-mwi-external \
+       res-mwi-external-ami \
+       res-parking \
+       res-phoneprov \
+       res-pjsip-phoneprov \
+       res-pjproject \
+       res-pktccops \
+       res-realtime \
+       res-resolver-unbound \
+       res-rtp-asterisk \
+       res-rtp-multicast \
+       res-security-log \
+       res-smdi \
+       res-snmp \
+       res-sorcery \
+       res-sorcery-memory-cache \
+       res-speech \
+       res-srtp \
+       res-stasis \
+       res-stasis-answer \
+       res-stasis-device-state \
+       res-stasis-mailbox \
+       res-stasis-playback \
+       res-stasis-recording \
+       res-stasis-snoop \
+       res-statsd \
+       res-stun-monitor \
+       res-timing-dahdi \
+       res-timing-pthread \
+       res-timing-timerfd \
+       res-xmpp \
+       voicemail
+
+UTILS_AVAILABLE:= \
+       aelparse \
+       astcanary \
+       astdb2sqlite3 \
+       astdb2bdb \
+       check_expr \
+       check_expr2 \
+       conf2ael \
+       muted \
+       smsq \
+       stereorize \
+       streamplayer
+
 AST_ENABLE:=
 
+PKG_CONFIG_DEPENDS:= \
+       $(patsubst %,CONFIG_PACKAGE_$(PKG_NAME)-%,$(MODULES_AVAILABLE)) \
+       $(patsubst %,CONFIG_PACKAGE_$(PKG_NAME)-util-%,$(subst _,-,$(UTILS_AVAILABLE))) \
+       CONFIG_ASTERISK15_LOW_MEMORY
+
+include $(INCLUDE_DIR)/uclibc++.mk
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/host-build.mk
 
@@ -105,29 +385,29 @@ $(foreach b,$(8),$(call Package/asterisk15/install/sbin,$$(1),$(b));)
 endef
 
 define BuildAsterisk15Util
-  define Package/asterisk15-util-$(1)
+  define Package/asterisk15-util-$(subst _,-,$(1))
   $$(call Package/asterisk15/Default)
     TITLE:=$(1) utility
-    DEPENDS:=asterisk15 $(patsubst +%,+PACKAGE_asterisk15-util-$(1):%,$(3))
-    ifneq ($$(CONFIG_PACKAGE_asterisk15-util-$(1)),)
+    DEPENDS:=asterisk15 $(patsubst +%,+PACKAGE_asterisk15-util-$(subst _,-,$(1)):%,$(3))
+    ifneq ($$(CONFIG_PACKAGE_asterisk15-util-$(subst _,-,$(1))),)
     AST_ENABLE+=$(1)
     endif
   endef
 
-  define Package/asterisk15-util-$(1)/conffiles
+  define Package/asterisk15-util-$(subst _,-,$(1))/conffiles
 $(subst $(space),$(newline),$(foreach c,$(4),/etc/$(c)))
   endef
 
-  define Package/asterisk15-util-$(1)/description
+  define Package/asterisk15-util-$(subst _,-,$(1))/description
 $(2)
   endef
 
-  define Package/asterisk15-util-$(1)/install
+  define Package/asterisk15-util-$(subst _,-,$(1))/install
 $(call Package/asterisk15/install/sbin,$$(1),$(1))
 $(foreach c,$(4),$(call Package/asterisk15/install/util-conffile,$$(1),$(c));)
   endef
 
-  $$(eval $$(call BuildPackage,asterisk15-util-$(1)))
+  $$(eval $$(call BuildPackage,asterisk15-util-$(subst _,-,$(1))))
 endef
 
 define Package/asterisk15/Default
@@ -148,7 +428,7 @@ define Package/asterisk15
 $(call Package/asterisk15/Default)
   TITLE:=Complete open source PBX, v$(PKG_VERSION)
   MENU:=1
-  DEPENDS:=+jansson +libcap +libedit +libncurses +libopenssl +libpopt +libsqlite3 +libstdcpp +libuuid +libxml2 +libxslt +zlib
+  DEPENDS:=$(CXX_DEPENDS) +jansson +libcap +libedit +libncurses +libopenssl +libsqlite3 +libuuid +libxml2 +zlib
 endef
 
 define Package/asterisk15/description
@@ -262,7 +542,7 @@ CONFIGURE_ARGS+= \
        --without-osptk \
        $(if $(CONFIG_PACKAGE_$(PKG_NAME)-pbx-lua),--with-lua="$(STAGING_DIR)/usr",--without-lua) \
        $(if $(CONFIG_PACKAGE_$(PKG_NAME)-pgsql),--with-postgres="$(STAGING_DIR)/usr",--without-postgres) \
-       --with-popt="$(STAGING_DIR)/usr" \
+       $(if $(CONFIG_PACKAGE_$(PKG_NAME)-util-smsq),--with-popt="$(STAGING_DIR)/usr",--without-popt) \
        $(if $(CONFIG_PACKAGE_$(PKG_NAME)-chan-console),--with-portaudio="$(STAGING_DIR)/usr",--without-portaudio) \
        --without-pwlib \
        --without-radius \
@@ -277,8 +557,7 @@ CONFIGURE_ARGS+= \
        $(if $(CONFIG_PACKAGE_$(PKG_NAME)-res-resolver-unbound),--with-unbound="$(STAGING_DIR)/usr",--without-unbound) \
        $(if $(CONFIG_PACKAGE_$(PKG_NAME)-format-ogg-vorbis),--with-vorbis="$(STAGING_DIR)/usr",--without-vorbis) \
        --without-vpb \
-       --with-z="$(STAGING_DIR)/usr" \
-       --with-sounds-cache="$(DL_DIR)"
+       --with-z="$(STAGING_DIR)/usr"
 
 ifeq ($(CONFIG_PACKAGE_$(PKG_NAME)-codec-speex)$(CONFIG_PACKAGE_$(PKG_NAME)-format-ogg-speex)$(CONFIG_PACKAGE_$(PKG_NAME)-func-speex),)
 CONFIGURE_ARGS+= \
@@ -312,7 +591,7 @@ CONFIGURE_ARGS+= \
        --with-srtp="$(STAGING_DIR)/usr"
 endif
 
-ifeq ($(CONFIG_PACKAGE_$(PKG_NAME)-pjsip)$(CONFIG_PACKAGE_$(PKG_NAME)-res-pjproject)$(CONFIG_PACKAGE_$(PKG_NAME)-res-rtp-asterisk)$(CONFIG_PACKAGE_$(PKG_NAME)-res-sdp-translator-pjmedia),)
+ifeq ($(CONFIG_PACKAGE_$(PKG_NAME)-pjsip)$(CONFIG_PACKAGE_$(PKG_NAME)-res-pjproject)$(CONFIG_PACKAGE_$(PKG_NAME)-res-rtp-asterisk),)
 CONFIGURE_ARGS+= \
        --without-pjproject
 else
@@ -379,12 +658,18 @@ AST_MENUSELECT_OPTS = \
        --without-curses \
        --with-libxml2="$(STAGING_DIR_HOSTPKG)/usr"
 
+define Build/menuselect
+       CC="$(HOSTCC)" \
+       CFLAGS="$(HOST_CFLAGS) -I$(STAGING_DIR_HOSTPKG)/include/libxml2" \
+       LDFLAGS="$(HOST_LDFLAGS) -Wl,-rpath,$(STAGING_DIR_HOSTPKG)/lib" \
+       $(MAKE) -C "$(PKG_BUILD_DIR)/menuselect"
+endef
+
 define Build/Configure
        cd $(PKG_BUILD_DIR); \
                ./bootstrap.sh
        $(call Build/Configure/Default)
        cd $(PKG_BUILD_DIR)/menuselect; \
-               ./bootstrap.sh; \
                CC="$(HOSTCC)" \
                CFLAGS="$(HOST_CFLAGS) -I$(STAGING_DIR_HOSTPKG)/include/libxml2" \
                CONFIG_SITE= \
@@ -396,11 +681,9 @@ define Build/Configure
 endef
 
 define Build/Compile
-       CC="$(HOSTCC)" \
-       CFLAGS="$(HOST_CFLAGS) -I$(STAGING_DIR_HOSTPKG)/include/libxml2" \
-       LDFLAGS="$(HOST_LDFLAGS) -Wl,-rpath,$(STAGING_DIR_HOSTPKG)/lib" \
-       $(MAKE) -C "$(PKG_BUILD_DIR)/menuselect"
-       $(MAKE) -C "$(PKG_BUILD_DIR)" menuselect-tree
+       $(call Build/menuselect)
+       $(call Build/Compile/Default,menuselect-tree)
+
        cd "$(PKG_BUILD_DIR)" && MENUSELECT_ARGS= && \
                for cat in $(MENUSELECT_CATEGORIES); do \
                        MENUSELECT_ARGS="$$$$MENUSELECT_ARGS --disable-category $$$$cat"; \
@@ -420,13 +703,15 @@ define Build/Compile
                        --disable BUILD_NATIVE \
                        $(if $(CONFIG_ASTERISK15_LOW_MEMORY),--enable LOW_MEMORY) \
                        menuselect.makeopts
-       # Hack:
+
        # When changing anything in MENUSELECT_CFLAGS the file ".lastclean"
        # gets deleted. E.g. when compiling on x86 for x86 "--disable
        # BUILD_NATIVE" changes MENUSELECT_CFLAGS and the file gets removed.
        # But that will result in a rebuild attempt of menuselect which will
-       # likely fail. Prevent that by recreating ".lastclean".
-       $(CP) "$(PKG_BUILD_DIR)/.cleancount" "$(PKG_BUILD_DIR)/.lastclean"
+       # likely fail. Prevent that by recreating ".lastclean" and menuselect.
+       $(call Build/Compile/Default,.lastclean)
+       $(call Build/menuselect)
+
        $(call Build/Compile/Default,all install samples)
 endef
 
@@ -468,7 +753,7 @@ $(eval $(call BuildAsterisk15Module,app-confbridge,ConfBridge,Software bridge fo
 $(eval $(call BuildAsterisk15Module,app-controlplayback,Control playback,trivial application to control playback of a sound file,,,app_controlplayback,,))
 $(eval $(call BuildAsterisk15Module,app-dahdiras,Execute an ISDN RAS,support for executing an ISDN RAS using DAHDI,+asterisk15-chan-dahdi,,app_dahdiras,,))
 $(eval $(call BuildAsterisk15Module,app-dictate,Virtual dictation machine,virtual dictation machine application,,,app_dictate,,))
-$(eval $(call BuildAsterisk15Module,app-directed_pickup,Directed call pickup,support for directed call pickup,,,app_directed_pickup,,))
+$(eval $(call BuildAsterisk15Module,app-directed-pickup,Directed call pickup,support for directed call pickup,,,app_directed_pickup,,))
 $(eval $(call BuildAsterisk15Module,app-directory,Extension directory,provide a directory of extensions,,,app_directory,,))
 $(eval $(call BuildAsterisk15Module,app-disa,Direct Inward System Access,Direct Inward System Access,,,app_disa,,))
 $(eval $(call BuildAsterisk15Module,app-dumpchan,Dump info about channel,application to dump channel variables,,,app_dumpchan,,))
@@ -499,12 +784,12 @@ $(eval $(call BuildAsterisk15Module,app-sayunixtime,Say Unix time,an application
 $(eval $(call BuildAsterisk15Module,app-senddtmf,Send DTMF digits,Sends arbitrary DTMF digits,,,app_senddtmf,,))
 $(eval $(call BuildAsterisk15Module,app-sendtext,Send text,transmit a text message,,,app_sendtext,,))
 $(eval $(call BuildAsterisk15Module,app-skel,Skeleton [sample],skeleton for development of an Asterisk application,,app_skel.conf,app_skel,,))
-$(eval $(call BuildAsterisk15Module,app-sms,SMS,SMS support (ETSI ES 201 912 protocol 1),+libpopt +libstdcpp,,app_sms,,))
+$(eval $(call BuildAsterisk15Module,app-sms,SMS,SMS support (ETSI ES 201 912 protocol 1),,,app_sms,,))
 $(eval $(call BuildAsterisk15Module,app-softhangup,Hang up requested channel,SoftHangup application,,,app_softhangup,,))
 $(eval $(call BuildAsterisk15Module,app-speech,Dialplan Speech,Dialplan Speech Applications,+asterisk15-res-speech,,app_speech_utils,,))
 $(eval $(call BuildAsterisk15Module,app-stack,Stack applications,Stack applications Gosub Return etc.,+asterisk15-res-agi,,app_stack,,))
 $(eval $(call BuildAsterisk15Module,app-stasis,Stasis dialplan,Stasis dialplan application,+$(PKG_NAME)-res-stasis,,app_stasis,,))
-$(eval $(call BuildAsterisk15Module,app-statsd,statsd dialplan,statsd dialplan,+$(PKG_NAME)-res_statsd,,app_statsd,,))
+$(eval $(call BuildAsterisk15Module,app-statsd,statsd dialplan,statsd dialplan,+$(PKG_NAME)-res-statsd,,app_statsd,,))
 $(eval $(call BuildAsterisk15Module,app-stream-echo,Stream echo,stream echo,,,app_stream_echo,,))
 $(eval $(call BuildAsterisk15Module,app-system,System exec,support for executing system commands,,,app_system,,))
 $(eval $(call BuildAsterisk15Module,app-talkdetect,File playback with audio detect,for file playback with audio detect,,,app_talkdetect,,))
@@ -626,8 +911,8 @@ $(eval $(call BuildAsterisk15Module,pbx-loopback,Loopback switch,loopback PBX mo
 $(eval $(call BuildAsterisk15Module,pbx-lua,Lua,provides Lua resources for Asterisk,+liblua,extensions.lua,pbx_lua,,))
 $(eval $(call BuildAsterisk15Module,pbx-realtime,Realtime Switch,realtime switch support,,,pbx_realtime,,))
 $(eval $(call BuildAsterisk15Module,pbx-spool,Call Spool,outgoing call spool support,,,pbx_spool,,))
-$(eval $(call BuildAsterisk15Module,pgsql,PostgreSQL,PostgreSQL support,+libpq @!arc,cel_pgsql.conf cdr_pgsql.conf res_pgsql.conf,cel_pgsql cdr_pgsql res_config_pgsql,,))
-$(eval $(call BuildAsterisk15Module,pjsip,pjsip channel,the channel pjsip,+asterisk15-res-sorcery +asterisk15-res-pjproject +libpjsip +libpjmedia +libpjnath +libpjsip-simple +libpjsip-ua +libpjsua +libpjsua2,pjsip.conf pjsip_notify.conf pjsip_wizard.conf,chan_pjsip func_pjsip_aor func_pjsip_contact func_pjsip_endpoint res_pjsip res_pjsip_acl res_pjsip_authenticator_digest res_pjsip_caller_id res_pjsip_config_wizard res_pjsip_dialog_info_body_generator res_pjsip_diversion res_pjsip_dlg_options res_pjsip_dtmf_info res_pjsip_empty_info res_pjsip_endpoint_identifier_anonymous res_pjsip_endpoint_identifier_ip res_pjsip_endpoint_identifier_user res_pjsip_exten_state res_pjsip_header_funcs res_pjsip_history res_pjsip_logger res_pjsip_messaging res_pjsip_mwi res_pjsip_mwi_body_generator res_pjsip_nat res_pjsip_notify res_pjsip_one_touch_record_info res_pjsip_outbound_authenticator_digest res_pjsip_outbound_publish res_pjsip_outbound_registration res_pjsip_path res_pjsip_pidf_body_generator res_pjsip_pidf_digium_body_supplement res_pjsip_pidf_eyebeam_body_supplement res_pjsip_publish_asterisk res_pjsip_pubsub res_pjsip_refer res_pjsip_registrar res_pjsip_registrar_expire res_pjsip_rfc3326 res_pjsip_sdp_rtp res_pjsip_send_to_voicemail res_pjsip_session res_pjsip_sips_contact res_pjsip_t38 res_pjsip_transport_management res_pjsip_transport_websocket res_pjsip_xpidf_body_generator,,))
+$(eval $(call BuildAsterisk15Module,pgsql,PostgreSQL,PostgreSQL support,+libpq,cel_pgsql.conf cdr_pgsql.conf res_pgsql.conf,cel_pgsql cdr_pgsql res_config_pgsql,,))
+$(eval $(call BuildAsterisk15Module,pjsip,pjsip channel,the channel pjsip,+asterisk15-res-sorcery +asterisk15-res-pjproject +libpjsip +libpjmedia +libpjnath +libpjsip-simple +libpjsip-ua +libpjsua +libpjsua2,pjsip.conf pjsip_notify.conf pjsip_wizard.conf,chan_pjsip func_pjsip_aor func_pjsip_contact func_pjsip_endpoint res_pjsip res_pjsip_acl res_pjsip_authenticator_digest res_pjsip_caller_id res_pjsip_config_wizard res_pjsip_dialog_info_body_generator res_pjsip_diversion res_pjsip_dlg_options res_pjsip_dtmf_info res_pjsip_empty_info res_pjsip_endpoint_identifier_anonymous res_pjsip_endpoint_identifier_ip res_pjsip_endpoint_identifier_user res_pjsip_exten_state res_pjsip_header_funcs res_pjsip_history res_pjsip_logger res_pjsip_messaging res_pjsip_mwi res_pjsip_mwi_body_generator res_pjsip_nat res_pjsip_notify res_pjsip_one_touch_record_info res_pjsip_outbound_authenticator_digest res_pjsip_outbound_publish res_pjsip_outbound_registration res_pjsip_path res_pjsip_pidf_body_generator res_pjsip_pidf_digium_body_supplement res_pjsip_pidf_eyebeam_body_supplement res_pjsip_publish_asterisk res_pjsip_pubsub res_pjsip_refer res_pjsip_registrar res_pjsip_registrar_expire res_pjsip_rfc3326 res_pjsip_sdp_rtp res_pjsip_send_to_voicemail res_pjsip_session res_pjsip_sips_contact res_pjsip_t38 res_pjsip_transport_websocket res_pjsip_xpidf_body_generator,,))
 $(eval $(call BuildAsterisk15Module,res-adsi,Provide ADSI,Analog Display Services Interface capability,,,res_adsi,,))
 $(eval $(call BuildAsterisk15Module,res-ael-share,Shareable AEL code,support for shareable AEL code mainly between internal and external modules,,,res_ael_share,,))
 $(eval $(call BuildAsterisk15Module,res-agi,Asterisk Gateway Interface,Support for the Asterisk Gateway Interface extension,+asterisk15-res-speech,,res_agi,,))
@@ -691,7 +976,6 @@ $(eval $(call BuildAsterisk15Module,res-realtime,RealTime CLI,RealTime CLI,,,res
 $(eval $(call BuildAsterisk15Module,res-resolver-unbound,Unbound DNS resolver,Unbound DNS resolver,+libunbound,resolver_unbound.conf,res_resolver_unbound,,))
 $(eval $(call BuildAsterisk15Module,res-rtp-asterisk,RTP stack,Supports RTP and RTCP with Symmetric RTP support for NAT traversal,+libpjsip +libpjmedia +libpjnath +libpjsip-simple +libpjsip-ua +libpjsua +libpjsua2,rtp.conf,res_rtp_asterisk,,))
 $(eval $(call BuildAsterisk15Module,res-rtp-multicast,RTP multicast engine,Multicast RTP Engine,,,res_rtp_multicast,,))
-$(eval $(call BuildAsterisk15Module,res-sdp-translator-pjmedia,PJMEDIA SDP translator,PJMEDIA SDP translator,+libpjsua2,,res_sdp_translator_pjmedia,,))
 $(eval $(call BuildAsterisk15Module,res-security-log,Security event logging,security event logging,,,res_security_log,,))
 $(eval $(call BuildAsterisk15Module,res-smdi,Provide SMDI,Simple Message Desk Interface capability,,smdi.conf,res_smdi,,))
 $(eval $(call BuildAsterisk15Module,res-snmp,SNMP [Sub]Agent for Asterisk,SNMP Agent / SubAgent,+libnetsnmp,res_snmp.conf,res_snmp,,))
@@ -724,14 +1008,14 @@ $(eval $(call BuildAsterisk15Module,voicemail,Voicemail,voicemail related module
 ################################
 # $(eval $(call BuildAsterisk15Util,Utility,Description,Dependencies,Configuration Files))
 
-$(eval $(call BuildAsterisk15Util,aelparse,Check extensions.ael file.,,))
+$(eval $(call BuildAsterisk15Util,aelparse,Check extensions.ael file.,+$(PKG_NAME)-pbx-ael,))
 $(eval $(call BuildAsterisk15Util,astcanary,Assures Asterisk no threads have gone missing.,,))
 $(eval $(call BuildAsterisk15Util,astdb2sqlite3,Convert astdb to SQLite 3.,,))
 $(eval $(call BuildAsterisk15Util,astdb2bdb,Convert astdb back to Berkeley DB 1.86.,,))
 $(eval $(call BuildAsterisk15Util,check_expr,Expression checker [older version].,,))
 $(eval $(call BuildAsterisk15Util,check_expr2,Expression checker [newer version].,,))
-$(eval $(call BuildAsterisk15Util,conf2ael,Convert .conf to .ael.,,))
+$(eval $(call BuildAsterisk15Util,conf2ael,Convert .conf to .ael.,+$(PKG_NAME)-pbx-ael,))
 $(eval $(call BuildAsterisk15Util,muted,Listens for AMI events. Mutes soundcard during call.,,muted.conf))
-$(eval $(call BuildAsterisk15Util,smsq,Send messages from command line.,,))
+$(eval $(call BuildAsterisk15Util,smsq,Send messages from command line.,+libpopt,))
 $(eval $(call BuildAsterisk15Util,stereorize,Merge two mono WAV-files to one stereo WAV-file.,,))
 $(eval $(call BuildAsterisk15Util,streamplayer,A utility for reading from a raw TCP stream [MOH source].,,))