[packages] glibmm: remove missing macros patch
[openwrt/svn-archive/archive.git] / net / asterisk-addons-1.4.x / Makefile
index 1824fac12e8e9aa05b8f6f69332626a35469a8d0..7fe91b5673a567ce7bc615e36f485338688c4152 100644 (file)
@@ -4,17 +4,18 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=asterisk-addons
-PKG_VERSION:=1.4.2
+PKG_VERSION:=1.4.8
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://ftp.digium.com/pub/asterisk/old-releases/
-PKG_MD5SUM:=c080b02e6ddc81dab6a64691af890805
+PKG_SOURCE_URL:=http://downloads.digium.com/pub/asterisk/releases/
+PKG_MD5SUM:=d4e75c39f737b5ba2a75a4420e1a5a78
+
+PKG_FIXUP = libtool
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -24,6 +25,7 @@ define Package/asterisk-addons/Default
   CATEGORY:=Network
   TITLE:=Asterisk addons
   URL:=http://www.asterisk.org/
+  MAINTAINER:=Hans Zandbelt <hans.zandbelt@gmail.com>
 endef
 
 define Package/asterisk-addons/Default/description
@@ -79,14 +81,17 @@ $(call Package/asterisk-addons/Default/description)
  This package contains MySQL support modules for Asterisk.
 endef
 
+
 EXTRA_CFLAGS:=$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)
 EXTRA_LDFLAGS:=$(TARGET_LDFLAGS)
+
 ifneq ($(SDK)$(CONFIG_PACKAGE_asterisk14-mysql),)
   EXTRA_CFLAGS+= -I$(STAGING_DIR)/usr/include/mysql
   EXTRA_LDFLAGS+= -L$(STAGING_DIR)/usr/lib/mysql
 endif
 
 CONFIGURE_ARGS += \
+       --with-asterisk="$(STAGING_DIR)/usr" \
        --with-bluetooth="$(STAGING_DIR)/usr" \
        --with-ncurses="$(STAGING_DIR)/usr" \
        --with-mysqlclient="$(STAGING_DIR)/usr" \
@@ -98,7 +103,6 @@ define Build/Configure
        ( cd $(PKG_BUILD_DIR); ./bootstrap.sh )
        $(call Build/Configure/Default,,,)
        $(call Build/Configure/Default,,,asterisk-ooh323c)
-       $(call libtool_disable_rpath)
 endef
 
 # XXX: explanations
@@ -107,12 +111,13 @@ endef
 
 MAKE_ARGS:= \
        AM_CFLAGS="$(TARGET_CFLAGS)" \
-       OPTIMIZE="$(TARGET_CFLAGS)" \
+       OPTIMIZE="$(TARGET_CFLAGS) -DLOW_MEMORY" \
        OPTIONS="" \
+       NOISY_BUILD="yes" \
        BLUETOOTH_LIB="$(TARGET_LDFLAGS) -lbluetooth" \
 
 MAKE_VARS:= \
-       CFLAGS="$(EXTRA_CFLAGS) -DLOW_MEMORY" \
+       CFLAGS="$(EXTRA_CFLAGS)" \
        LDFLAGS="$(EXTRA_LDFLAGS)" \
 
 define Build/Compile
@@ -121,7 +126,6 @@ define Build/Compile
        $(MAKE) -C "$(PKG_BUILD_DIR)" \
                $(MAKE_ARGS) \
                all
-       $(call libtool_fixup_libdir,$(PKG_INSTALL_DIR))
        $(MAKE_VARS) \
        $(MAKE) -C "$(PKG_BUILD_DIR)" \
                $(MAKE_ARGS) \