baresip: update to 0.5.6
[feed/telephony.git] / net / baresip / Makefile
index ef528812267df5f97bc5553f8c3dc55dd8e0d42c..f399ab4de91e80cebad0d3939c33be8b1f108e8c 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2010-2014 OpenWrt.org
+# Copyright (C) 2010-2017 OpenWrt.org
 # Copyright (C) 2010 Alfred E. Heggestad
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -9,12 +9,16 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=baresip
-PKG_VERSION:=0.4.11
+PKG_VERSION:=0.5.6
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.creytiv.com/pub/
-PKG_MD5SUM:=bf25d14749ca286716c9b23108472c8a
+PKG_HASH:=148defef160842e0247af92c84bb0c8de4b36ffa68cf3a87c4cd7e510cddd00c
+
+PKG_LICENSE:=BSD-3-Clause
+PKG_LICENSE_FILES:=docs/COPYING
+PKG_MAINTAINER:=Jiri Slachta <slachta@cesnet.cz>
 
 baresip-mods:= \
        alsa \
@@ -24,13 +28,12 @@ baresip-mods:= \
        evdev \
        g711 \
        g722 \
+       g726 \
+       opus \
        oss \
-       sdl \
-       speex \
        stdio \
-       uuid \
        v4l \
-       v4l2 \
+       v4l2
 
 PKG_CONFIG_DEPENDS:= \
        $(patsubst %,CONFIG_PACKAGE_baresip-mod-%,$(baresip-mods)) \
@@ -48,26 +51,26 @@ define Package/baresip
 $(call Package/baresip/Default)
   TITLE:=Portable and modular SIP User-Agent with A/V support
   DEPENDS:=+libre +librem +libpthread
+  MENU:=1
 endef
 
-
 baresip-mod-alsa      := USE_ALSA
-baresip-mod-avcodec   := USE_FFMPEG
-baresip-mod-avformat  := USE_FFMPEG_AVFORMAT
+baresip-mod-avcodec   := USE_AVCODEC
+baresip-mod-avformat  := USE_AVFORMAT
 baresip-mod-cons      := USE_CONS
 baresip-mod-evdev     := USE_EVDEV
 baresip-mod-g711      := USE_G711
 baresip-mod-g722      := USE_G722
+baresip-mod-g726      := USE_G726
+baresip-mod-opus      := USE_OPUS
 baresip-mod-oss       := USE_OSS
-baresip-mod-sdl       := USE_SDL
-baresip-mod-speex     := USE_SPEEX
 baresip-mod-stdio     := USE_STDIO
-baresip-mod-uuid      := USE_UUID
 baresip-mod-v4l       := USE_V4L
 baresip-mod-v4l2      := USE_V4L2
 
 BARESIP_MOD_OPTIONS:= \
        MOD_AUTODETECT= \
+       EXTRA_MODULES="dtmfio" \
        $(foreach m,$(baresip-mods),$(baresip-mod-$(m))=$(if $(CONFIG_PACKAGE_baresip-mod-$(m)),1))
 
 TARGET_CFLAGS += $(FPIC)
@@ -94,7 +97,7 @@ define Package/baresip/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/baresip $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/usr/lib/baresip/modules
-       $(CP) \
+       $(INSTALL_BIN) \
                $(PKG_INSTALL_DIR)/usr/lib/baresip/modules/{account,auloop,contact,ice,menu,stun,turn}.so \
                $(1)/usr/lib/baresip/modules/.
        $(INSTALL_DIR) $(1)/usr/share/baresip
@@ -103,13 +106,14 @@ define Package/baresip/install
        $(INSTALL_BIN) ./files/baresip.init $(1)/etc/init.d/baresip
 endef
 
-
-#
+##################
+# Baresip modules
 # 1. Name
 # 2. Title
 # 3. Files
-# 4. Depends
-#
+# 4. Dependencies
+##################
+
 define BuildPlugin
 
   define Package/baresip-mod-$(1)
@@ -130,20 +134,20 @@ define BuildPlugin
   $$(eval $$(call BuildPackage,baresip-mod-$(1)))
 endef
 
-
 $(eval $(call BuildPackage,baresip))
 
 $(eval $(call BuildPlugin,alsa,ALSA audio driver,alsa,+PACKAGE_baresip-mod-alsa:alsa-lib))
 $(eval $(call BuildPlugin,avcodec,FFmpeg video codecs,avcodec,+PACKAGE_baresip-mod-avcodec:libffmpeg-full))
 $(eval $(call BuildPlugin,avformat,FFmpeg video source,avformat,+PACKAGE_baresip-mod-avformat:libffmpeg-full))
 $(eval $(call BuildPlugin,cons,console UI,cons,))
+$(eval $(call BuildPlugin,dtmfio,DTMF input/output,dtmfio,))
 $(eval $(call BuildPlugin,evdev,input event device UI,evdev,))
 $(eval $(call BuildPlugin,g711,G.711 audio codec,g711,))
 $(eval $(call BuildPlugin,g722,G.722 audio codec,g722,+PACKAGE_baresip-mod-g722:libspandsp))
-$(eval $(call BuildPlugin,sdl,SDL video display,sdl,+libsdl))
+$(eval $(call BuildPlugin,g726,G.726 audio codec,g726,+PACKAGE_baresip-mod-g726:libspandsp))
+$(eval $(call BuildPlugin,httpd,Webserver UI module,httpd,))
+$(eval $(call BuildPlugin,opus,Opus audio codec,opus,+PACKAGE_baresip-mod-opus:libopus))
 $(eval $(call BuildPlugin,oss,OSS audio driver,oss,))
-$(eval $(call BuildPlugin,speex,Speex audio codec,speex,+PACKAGE_baresip-mod-speex:libspeex))
 $(eval $(call BuildPlugin,stdio,standard I/O UI,stdio,))
-$(eval $(call BuildPlugin,uuid,UUID,uuid,+libuuid))
 $(eval $(call BuildPlugin,v4l,Video4Linux video source,v4l,+PACKAGE_baresip-mod-v4l:libv4l))
 $(eval $(call BuildPlugin,v4l2,Video4Linux2 video source,v4l2,+PACKAGE_baresip-mod-v4l2:libv4l))