Merge pull request #19372 from cotequeiroz/libgd
[feed/packages.git] / net / bind / Makefile
index 44219e424ad112441f83b2b579317b5ff617283c..bc4a9a877142cadd691566663efe7845c4a67946 100644 (file)
@@ -9,8 +9,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bind
-PKG_VERSION:=9.17.10
-PKG_RELEASE:=1
+PKG_VERSION:=9.18.7
+PKG_RELEASE:=$(AUTORELEASE)
 USERID:=bind=57:bind=57
 
 PKG_MAINTAINER:=Noah Meyerhans <frodo@morgul.net>
@@ -22,7 +22,7 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:= \
        https://www.mirrorservice.org/sites/ftp.isc.org/isc/bind9/$(PKG_VERSION) \
        https://ftp.isc.org/isc/bind9/$(PKG_VERSION)
-PKG_HASH:=26a90d28ad694029e480fadcdf60b6219e8128a02d3dd594f6c1a83d002890fd
+PKG_HASH:=9e2acf1698f49d70ad12ffbad39ec6716a7da524e9ebd98429c7c70ba1262981
 
 PKG_FIXUP:=autoreconf
 PKG_REMOVE_FILES:=aclocal.m4 libtool.m4
@@ -31,17 +31,18 @@ PKG_INSTALL:=1
 PKG_USE_MIPS16:=0
 PKG_BUILD_PARALLEL:=1
 
-PKG_BUILD_DEPENDS:=nghttp2
-
 PKG_CONFIG_DEPENDS := \
        CONFIG_BIND_LIBJSON \
-       CONFIG_BIND_LIBXML2
+       CONFIG_BIND_LIBXML2 \
+       CONFIG_BIND_ENABLE_DOH
 
 PKG_BUILD_DEPENDS += BIND_LIBXML2:libxml2 BIND_LIBJSON:libjson-c
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/nls.mk
 
+DISABLE_NLS:=
+
 define Package/bind/Default
   SECTION:=net
   CATEGORY:=Network
@@ -59,7 +60,7 @@ define Package/bind-libs
        +libpthread \
        +libatomic \
        +libuv \
-       +libnghttp2 \
+       +BIND_ENABLE_DOH:libnghttp2 \
        +BIND_LIBXML2:libxml2 \
        +BIND_LIBJSON:libjson-c
   TITLE:=bind shared libraries
@@ -69,6 +70,7 @@ endef
 define Package/bind-server
   $(call Package/bind/Default)
   TITLE+= DNS server
+  DEPENDS+= +libcap
 endef
 
 define Package/bind-server/config
@@ -95,7 +97,8 @@ define Package/bind-tools
        +bind-nslookup \
        +bind-dnssec \
        +bind-host \
-       +bind-rndc
+       +bind-rndc \
+       +bind-ddns-confgen
 endef
 
 define Package/bind-rndc
@@ -130,19 +133,21 @@ define Package/bind-nslookup
          200:/usr/bin/nslookup:/usr/libexec/nslookup-bind
 endef
 
+define Package/bind-ddns-confgen
+  $(call Package/bind/Default)
+  TITLE+= administration tools (ddns-confgen and tsig-keygen only)
+endef
+
 export BUILD_CC="$(TARGET_CC)"
 
 TARGET_LDFLAGS += -Wl,--gc-sections,--as-needed
 
 CONFIGURE_ARGS += \
-       --disable-linux-caps \
        --with-openssl="$(STAGING_DIR)/usr" \
-       --with-libtool \
        --without-lmdb \
        --enable-epoll \
        --without-gssapi \
        --without-readline \
-       --without-python \
        --sysconfdir=/etc/bind
 
 ifdef CONFIG_BIND_LIBJSON
@@ -162,6 +167,14 @@ else
                --with-libxml2=no
 endif
 
+ifdef CONFIG_BIND_ENABLE_DOH
+       CONFIGURE_ARGS += \
+               --enable-doh
+else
+       CONFIGURE_ARGS += \
+               --disable-doh
+endif
+
 CONFIGURE_VARS += \
        BUILD_CC="$(TARGET_CC)" \
 
@@ -259,6 +272,12 @@ define Package/bind-nslookup/install
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/nslookup $(1)/usr/libexec/nslookup-bind
 endef
 
+define Package/bind-ddns-confgen/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/ddns-confgen $(1)/usr/sbin/ddns-confgen
+       $(LN) -s ddns-confgen $(1)/usr/sbin/tsig-keygen
+endef
+
 $(eval $(call BuildPackage,bind-libs))
 $(eval $(call BuildPackage,bind-server))
 $(eval $(call BuildPackage,bind-server-filter-aaaa))
@@ -270,3 +289,4 @@ $(eval $(call BuildPackage,bind-dnssec))
 $(eval $(call BuildPackage,bind-host))
 $(eval $(call BuildPackage,bind-dig))
 $(eval $(call BuildPackage,bind-nslookup))
+$(eval $(call BuildPackage,bind-ddns-confgen))