bind: bump PKG_RELEASE
[feed/packages.git] / net / bind / Makefile
index 7a05d1c6f929677e5cb109b57d4622d8a0f2c35e..dfa48cb5268b2709b1d64e68eadaa893acccc2e7 100644 (file)
@@ -9,8 +9,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bind
-PKG_VERSION:=9.18.0
-PKG_RELEASE:=$(AUTORELEASE)
+PKG_VERSION:=9.18.11
+PKG_RELEASE:=3
 USERID:=bind=57:bind=57
 
 PKG_MAINTAINER:=Noah Meyerhans <frodo@morgul.net>
@@ -22,7 +22,7 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:= \
        https://www.mirrorservice.org/sites/ftp.isc.org/isc/bind9/$(PKG_VERSION) \
        https://ftp.isc.org/isc/bind9/$(PKG_VERSION)
-PKG_HASH:=56525bf5caf01fd8fd9d90910880cc0f8a90a27a97d169187d651d4ecf0c411c
+PKG_HASH:=8ff3352812230cbcbda42df87cad961f94163d3da457c5e4bef8057fd5df2158
 
 PKG_FIXUP:=autoreconf
 PKG_REMOVE_FILES:=aclocal.m4 libtool.m4
@@ -31,17 +31,19 @@ PKG_INSTALL:=1
 PKG_USE_MIPS16:=0
 PKG_BUILD_PARALLEL:=1
 
-PKG_BUILD_DEPENDS:=nghttp2
-
 PKG_CONFIG_DEPENDS := \
        CONFIG_BIND_LIBJSON \
-       CONFIG_BIND_LIBXML2
+       CONFIG_BIND_LIBXML2 \
+       CONFIG_BIND_ENABLE_DOH \
+       CONFIG_BIND_ENABLE_GSSAPI
 
 PKG_BUILD_DEPENDS += BIND_LIBXML2:libxml2 BIND_LIBJSON:libjson-c
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/nls.mk
 
+DISABLE_NLS:=
+
 define Package/bind/Default
   SECTION:=net
   CATEGORY:=Network
@@ -59,7 +61,9 @@ define Package/bind-libs
        +libpthread \
        +libatomic \
        +libuv \
-       +libnghttp2 \
+       +BIND_ENABLE_DOH:libnghttp2 \
+       +BIND_ENABLE_GSSAPI:krb5-libs \
+       +BIND_ENABLE_GSSAPI:libcomerr \
        +BIND_LIBXML2:libxml2 \
        +BIND_LIBJSON:libjson-c
   TITLE:=bind shared libraries
@@ -96,7 +100,8 @@ define Package/bind-tools
        +bind-nslookup \
        +bind-dnssec \
        +bind-host \
-       +bind-rndc
+       +bind-rndc \
+       +bind-ddns-confgen
 endef
 
 define Package/bind-rndc
@@ -131,18 +136,21 @@ define Package/bind-nslookup
          200:/usr/bin/nslookup:/usr/libexec/nslookup-bind
 endef
 
+define Package/bind-ddns-confgen
+  $(call Package/bind/Default)
+  TITLE+= administration tools (ddns-confgen and tsig-keygen only)
+endef
+
 export BUILD_CC="$(TARGET_CC)"
 
 TARGET_LDFLAGS += -Wl,--gc-sections,--as-needed
 
 CONFIGURE_ARGS += \
+       --disable-geoip \
        --with-openssl="$(STAGING_DIR)/usr" \
-       --with-libtool \
        --without-lmdb \
        --enable-epoll \
-       --without-gssapi \
        --without-readline \
-       --without-python \
        --sysconfdir=/etc/bind
 
 ifdef CONFIG_BIND_LIBJSON
@@ -162,6 +170,22 @@ else
                --with-libxml2=no
 endif
 
+ifdef CONFIG_BIND_ENABLE_DOH
+       CONFIGURE_ARGS += \
+               --enable-doh
+else
+       CONFIGURE_ARGS += \
+               --disable-doh
+endif
+
+ifdef CONFIG_BIND_ENABLE_GSSAPI
+       CONFIGURE_ARGS += \
+               --with-gssapi
+else
+       CONFIGURE_ARGS += \
+               --without-gssapi
+endif
+
 CONFIGURE_VARS += \
        BUILD_CC="$(TARGET_CC)" \
 
@@ -259,6 +283,12 @@ define Package/bind-nslookup/install
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/nslookup $(1)/usr/libexec/nslookup-bind
 endef
 
+define Package/bind-ddns-confgen/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/ddns-confgen $(1)/usr/sbin/ddns-confgen
+       $(LN) -s ddns-confgen $(1)/usr/sbin/tsig-keygen
+endef
+
 $(eval $(call BuildPackage,bind-libs))
 $(eval $(call BuildPackage,bind-server))
 $(eval $(call BuildPackage,bind-server-filter-aaaa))
@@ -270,3 +300,4 @@ $(eval $(call BuildPackage,bind-dnssec))
 $(eval $(call BuildPackage,bind-host))
 $(eval $(call BuildPackage,bind-dig))
 $(eval $(call BuildPackage,bind-nslookup))
+$(eval $(call BuildPackage,bind-ddns-confgen))