init script should be executable by default
[openwrt/svn-archive/archive.git] / net / bing / Makefile
index 81d8310bae38bd66a8e5df1a4d21560043e79c34..a42ae3949b6e562cb5c150a884b3e688836ba285 100644 (file)
@@ -1,9 +1,10 @@
+#
 # Copyright (C) 2006 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: Makefile 4603 2006-08-18 21:21:06Z mbm $
+# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -15,9 +16,9 @@ PKG_SOURCE:=$(PKG_NAME)_src-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://fgouget.free.fr/bing/
 PKG_MD5SUM:=60aaee55277672d0cc163bf3f0b3d53f
 PKG_CAT:=zcat
+TAR_OPTIONS += || true
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -31,11 +32,11 @@ define Package/bing
 endef
 
 define Build/Compile
-$(call Build/Compile/Default)
+       $(call Build/Compile/Default)
 endef
 
 define Package/bing/install
-       install -d -m0755 $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/usr/sbin
        $(CP) $(PKG_BUILD_DIR)/bing $(1)/usr/sbin/
 endef