[packages] openssh: remove ssh and scp symlinks to dropbear when openssh-client is
[openwrt/svn-archive/archive.git] / net / bing / Makefile
index 81d8310bae38bd66a8e5df1a4d21560043e79c34..c271e8f95095c48e2eafb32554e7fd51b5142e46 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: Makefile 4603 2006-08-18 21:21:06Z mbm $
 
 include $(TOPDIR)/rules.mk
 
@@ -14,10 +14,7 @@ PKG_RELEASE:=0
 PKG_SOURCE:=$(PKG_NAME)_src-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://fgouget.free.fr/bing/
 PKG_MD5SUM:=60aaee55277672d0cc163bf3f0b3d53f
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+TAR_OPTIONS += || true
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -25,18 +22,20 @@ define Package/bing
   SECTION:=net
   CATEGORY:=Network
   TITLE:=bing bandwidth measuring utility
-  DESCRIPTION:=\
-       bing evaluates the raw bandwidth of a link (PSTN, xDSL, Cable ...)
   URL:=http://fgouget.free.fr/bing/
 endef
 
+define Package/bing/description
+       bing evaluates the raw bandwidth of a link (PSTN, xDSL, Cable ...)
+endef
+
 define Build/Compile
-$(call Build/Compile/Default)
+       $(call Build/Compile/Default,bing)
 endef
 
 define Package/bing/install
-       install -d -m0755 $(1)/usr/sbin
-       $(CP) $(PKG_BUILD_DIR)/bing $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/bing $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,bing))