[packages] openssh: remove ssh and scp symlinks to dropbear when openssh-client is
[openwrt/svn-archive/archive.git] / net / bing / Makefile
index a42ae3949b6e562cb5c150a884b3e688836ba285..c271e8f95095c48e2eafb32554e7fd51b5142e46 100644 (file)
@@ -1,10 +1,9 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -15,29 +14,28 @@ PKG_RELEASE:=0
 PKG_SOURCE:=$(PKG_NAME)_src-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://fgouget.free.fr/bing/
 PKG_MD5SUM:=60aaee55277672d0cc163bf3f0b3d53f
-PKG_CAT:=zcat
 TAR_OPTIONS += || true
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-
 include $(INCLUDE_DIR)/package.mk
 
 define Package/bing
   SECTION:=net
   CATEGORY:=Network
   TITLE:=bing bandwidth measuring utility
-  DESCRIPTION:=\
-       bing evaluates the raw bandwidth of a link (PSTN, xDSL, Cable ...)
   URL:=http://fgouget.free.fr/bing/
 endef
 
+define Package/bing/description
+       bing evaluates the raw bandwidth of a link (PSTN, xDSL, Cable ...)
+endef
+
 define Build/Compile
-       $(call Build/Compile/Default)
+       $(call Build/Compile/Default,bing)
 endef
 
 define Package/bing/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_BUILD_DIR)/bing $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/bing $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,bing))