znc: Fix call to g++-uc
[openwrt/svn-archive/archive.git] / net / bitchx / Makefile
index c0310f7167dd6ddcb05e7f7bc0f828978bffe91d..9857bee364040809f69a6467f9e66613d349a203 100644 (file)
@@ -1,10 +1,9 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -17,7 +16,6 @@ PKG_SOURCE_URL:=http://bitchx.org/files/source/
 PKG_MD5SUM:=611d2dda222f00c10140236f4c331572
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/BitchX
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 PKG_BUILD_DEPENDS:=libncurses
 
@@ -33,10 +31,8 @@ define Package/bitchx
 endef
 
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+               CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all
        mkdir -p $(PKG_INSTALL_DIR)/tmp