[packages] mc: fixup broken symlinks to host automake (#6699)
[openwrt/svn-archive/archive.git] / net / bitchx / Makefile
index 598c959914bc7c88420b8ceb94087a0abf19e857..9857bee364040809f69a6467f9e66613d349a203 100644 (file)
@@ -1,10 +1,9 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -15,10 +14,8 @@ PKG_RELEASE:=1
 PKG_SOURCE:=ircii-pana-$(PKG_VERSION)-final.tar.gz
 PKG_SOURCE_URL:=http://bitchx.org/files/source/
 PKG_MD5SUM:=611d2dda222f00c10140236f4c331572
-PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/BitchX
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 PKG_BUILD_DEPENDS:=libncurses
 
@@ -34,10 +31,8 @@ define Package/bitchx
 endef
 
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+               CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all
        mkdir -p $(PKG_INSTALL_DIR)/tmp
@@ -68,7 +63,7 @@ define Package/bitchx/install
        $(INSTALL_DIR) $(1)/usr/bin $(1)/usr/lib $(1)/etc/init.d $(1)/tmp
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/* $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/etc/init.d/bitchxrc $(1)/etc/init.d/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/etc/init.d/bitchxrc $(1)/etc/init.d/
        $(CP) $(PKG_INSTALL_DIR)/tmp/.bitchxrc $(1)/tmp
 endef