[packages] ndyndns: Don't add host include paths.
[openwrt/svn-archive/archive.git] / net / bmon / Makefile
index d7fef3d42473e3cc66987704d2dc235579217b80..623526554ceeb2cf021ed431bcaae8041a8231e6 100644 (file)
@@ -1,24 +1,19 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bmon
 PKG_VERSION:=2.1.0
-PKG_RELEASE:=0
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://people.suug.ch/~tgr/bmon/files/
 PKG_MD5SUM:=3111a027907016c0902d67350c619df6
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,32 +22,28 @@ define Package/bmon
   CATEGORY:=Network
   DEPENDS:=+libncurses
   TITLE:=bmon is a portable bandwidth monitor
-  DESCRIPTION:=\
-       bmon is a portable bandwidth monitor \\\
-       and rate estimator running on various \\\
-       operating systems. It supports various \\\
-       input methods for different architectures.
   URL:=http://people.suug.ch/~tgr/bmon/
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --disable-cnt-workaround \
-               --disable-dbi \
-               --disable-rrd \
-               --disable-asound \
-       )
+define Package/bmon/description
+       bmon is a portable bandwidth monitor 
+       and rate estimator running on various 
+       operating systems. It supports various 
+       input methods for different architectures.
 endef
 
+CONFIGURE_ARGS += \
+       --disable-cnt-workaround \
+       --disable-dbi \
+       --disable-rrd \
+       --disable-asound \
 
-define Build/Compile
-       $(call Build/Compile/Default,all)
-endef
+CONFIGURE_VARS += \
+       ac_cv_lib_nl_nl_connect=no \
 
 define Package/bmon/install
-       install -d -m0755 $(1)/usr/sbin
-       install -m0755 $(PKG_BUILD_DIR)/src/bmon $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/bmon $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,bmon))
-