adding poc implementation for autostarting x11 applications
[openwrt/svn-archive/archive.git] / net / chillispot / Makefile
index 555a855205553e20737119f96454ed8daf8b434b..1a46a645849eabb3968ba12794ca3cfd88335d4f 100644 (file)
@@ -15,10 +15,7 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.chillispot.org/download
 PKG_MD5SUM:=9d2597756af3fa14d7331b4a3651fc9b
-PKG_CAT:=zcat
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -28,17 +25,19 @@ define Package/chillispot
   CATEGORY:=Network
   DEPENDS:=+kmod-tun
   TITLE:=Wireless LAN HotSpot controller
-  DESCRIPTION:=\
-       ChilliSpot is an open source captive portal or wireless LAN \\\
-       access point controller. It is used for authenticating users \\\
-       of a wireless LAN. It supports web based login which is today's \\\
-       standard for public HotSpots and it supports Wireless Protected \\\
-       Access (WPA) which is the standard of the future. Authentication, \\\
-       authorization and accounting (AAA) is handled by your favorite \\\
-       radius server.
   URL:=http://www.chillispot.org/
 endef
 
+define Package/chillispot/description
+       ChilliSpot is an open source captive portal or wireless LAN 
+       access point controller. It is used for authenticating users 
+       of a wireless LAN. It supports web based login which is today's 
+       standard for public HotSpots and it supports Wireless Protected 
+       Access (WPA) which is the standard of the future. Authentication, 
+       authorization and accounting (AAA) is handled by your favorite 
+       radius server.
+endef
+
 define Package/chillispot/conffiles
 /etc/chilli.conf
 endef
@@ -57,7 +56,7 @@ define Package/chillispot/install
        $(INSTALL_DIR) $(1)/etc
        $(INSTALL_DATA) $(PKG_BUILD_DIR)/doc/chilli.conf $(1)/etc/
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/chilli $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/chilli $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,chillispot))