Add luasocket, patch from OrazioPirataDelloSpazio
[openwrt/svn-archive/archive.git] / net / chrony / Makefile
index 2b05ef98b8a62a28912236970b31b80de1c0ea07..86a1c2e4d0cc7737d71d557d0e6abf549053a521 100644 (file)
@@ -1,37 +1,37 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
+# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=chrony
-PKG_VERSION:=1.21
+PKG_VERSION:=1.23
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:= ftp://chrony.sunsite.dk/projects/chrony/ \
        http://chrony.sunsite.dk/download/
-PKG_MD5SUM:=84f76a73dff5a3c9e9f11f3c29a4e93b
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_MD5SUM:=ffce77695e55d8efda19ab0b78309c23
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/chrony
+  SUBMENU:=Time Synchronization
   SECTION:=net
   CATEGORY:=Network
+  DEPENDS:=+libreadline +libncurses @!TARGET_avr32 @!powerpc
   TITLE:=NTP client/server for on-demand connections
-  DESCRIPTION:=\
-       A NTP implementation that has been specifically written to work well in the case of an intermittent \
-       (e.g. dial-on-demand) connection to the network where your NTP servers are.
   URL:=http://chrony.sunsite.dk/
-  MAINTAINER:=Richard Kunze <kunze-openwrt-chrony@tivano.de>
-  DEPENDS:=uclibc libreadline libncurses
+endef
+
+define Package/chrony/description
+       A NTP implementation that has been specifically written to work
+       well in the case of an intermittent (e.g. dial-on-demand)
+       connection to the network where your NTP servers are.
 endef
 
 define Package/chrony/conffiles
@@ -43,7 +43,8 @@ define Build/Configure
                        --target=$(GNU_TARGET_NAME) \
                        --prefix=/usr \
                        --with-readline-includes=$(STAGING_DIR)/usr/include \
-                       --with-readline-library=$(STAGING_DIR)/usr/lib \        )
+                       --with-readline-library=$(STAGING_DIR)/usr/lib \
+       )
 endef
 
 define Build/Compile
@@ -52,11 +53,11 @@ define Build/Compile
                prefix="$(PKG_INSTALL_DIR)/usr"
 endef
 
-define Package/chrony/install  
+define Package/chrony/install
        $(INSTALL_DIR) $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/usr/sbin/
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/chronyd $(1)$(PKG_INSTALL_DIR)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/chronyc $(1)$(PKG_INSTALL_DIR)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/chronyd $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/chronyc $(1)/usr/bin
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_DIR) $(1)/etc/config
        $(INSTALL_DIR) $(1)/etc/chrony