[Packages] Add softflowd package (#2748)
[openwrt/svn-archive/archive.git] / net / ctorrent / Makefile
index e5631f5ad863d8360a32e17cd6eb6a3631c864b7..ea85c71bf315e35c324168415fae30aff2535dd8 100644 (file)
@@ -1,4 +1,5 @@
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,60 +9,48 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ctorrent
-PKG_VERSION:=1.3.4-dnh2
+PKG_VERSION:=dnh3.2
 PKG_RELEASE:=1
-PKG_MD5SUM:=6635e2d0d0ee21faeb85d95cd93c137b
 
-PKG_SOURCE_URL:=http://www.rahul.net/dholmes/ctorrent/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-dnh2
-PKG_CAT:=zcat
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_SOURCE_URL:=http://www.rahul.net/dholmes/ctorrent/
+PKG_MD5SUM:=23b37cd7b558ad6a27974b311499bab6
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/ctorrent
+  SUBMENU:=BitTorrent
   SECTION:=net
   CATEGORY:=Network
+  DEPENDS:=+libopenssl +uclibcxx
   TITLE:=console-based BitTorrent client
-  DESCRIPTION:=CTorrent is a BitTorrent client written in the C programming language, known to\\\
-       be a very robust and mature programming language, which produces fast and\\\
-       optimized application.\\\
   URL:=http://www.rahul.net/dholmes/ctorrent/
 endef
+
+define Package/ctorrent/description
+ CTorrent is a BitTorrent client written in the C programming language, 
+ known to be a very robust and mature programming language, which produces 
+ fast and optimized application.
+endef
    
+CONFIGURE_VARS += \
+       CXX="g++-uc" \
+       CXXFLAGS="$$$$CXXFLAGS -fno-rtti" \
+
 define Build/Configure
-       (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include -I$(STAGING_DIR)/usr/include/openssl" \
-               LDFLAGS="-static -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
-               ./configure \
-               --target=$(GNU_TARGET_NAME) \
-               --host=$(GNU_TARGET_NAME) \
-               --build=$(GNU_HOST_NAME) \
-               --prefix=/usr \
-               --exec-prefix=/usr \
-               --bindir=/usr/bin \
-               --sbindir=/usr/sbin \
-               --libexecdir=/usr/lib \
-               --sysconfdir=/etc \
-               --datadir=/usr/share \
-               --localstatedir=/var \
-               --mandir=/usr/man \
-               --infodir=/usr/info \
-               --program-prefix="" \
-               --with-gnu-ld \
-       );
+       $(call Build/Configure/Default,)
+       $(call libtool_disable_rpath)
 endef
 
-define Build/Compile   
-  $(call Build/Compile/Default, DESTDIR=$(PKG_INSTALL_DIR)  install)
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) all
+       $(call libtool_fixup_libdir,$(PKG_INSTALL_DIR))
+       $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" install
 endef
-       
+
 define Package/ctorrent/install        
-       mkdir -p $(1)
-       $(CP) $(PKG_INSTALL_DIR)/* $(1)/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,ctorrent))