Update neon to 0.28.2 (#3592)
[openwrt/svn-archive/archive.git] / net / cutter / Makefile
index 2b99a551a96ff13cbf68b8576d3103cb60cfff5f..310a7b1615ebc1e0083a2b654b8be0ed7d93f7a1 100644 (file)
@@ -15,10 +15,8 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=http://www.lowth.com/cutter/software/
 PKG_MD5SUM:=50093db9b64277643969ee75b83ebbd1
-PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,22 +24,22 @@ define Package/cutter
   SECTION:=net
   CATEGORY:=Network
   TITLE:=allows an user to abort TCP/IP connections
-  DESCRIPTION:=\
-       Cutter is an open source program that allows Linux firewall \\\
-       administrators to abort TCP/IP connections routed over the \\\
-       firewall or router on which it is run.
   URL:=http://www.lowth.com/cutter/
 endef
+
+define Package/cutter/description
+       Cutter is an open source program that allows Linux firewall 
+       administrators to abort TCP/IP connections routed over the 
+       firewall or router on which it is run.
+endef
        
 define Build/Compile
        $(TARGET_CC) $(PKG_BUILD_DIR)/cutter.c -o $(PKG_BUILD_DIR)/cutter
-       $(INSTALL_DIR) $(PKG_INSTALL_DIR)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/cutter $(PKG_INSTALL_DIR)/usr/sbin/
 endef
        
 define Package/cutter/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/cutter $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/cutter $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,cutter))