flow-tools: Make zlib a build time dependency only.
[openwrt/svn-archive/archive.git] / net / dhcp / Makefile
index da75804c626d2e71eb2f0df1968df52fbb847cf0..681fddca5454b933c42e72ffc25d7ff6970a4329 100644 (file)
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dhcp
-PKG_VERSION:=3.0.3
+PKG_VERSION:=3.0.5
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.isc.org/isc/dhcp/
-PKG_MD5SUM:=f91416a0b8ed3fd0601688cf0b7df58f
+PKG_MD5SUM:=ce5d30d4645e4eab1f54561b487d1ec7
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
@@ -43,6 +43,9 @@ endef
 define Build/Configure
        # it's not GNU autoconf stuff
        (cd $(PKG_BUILD_DIR) ; \
+               UNAME_S=Linux \
+               UNAME_M=$(ARCH) \
+               UNAME_R=2.4.34 \
                ./configure \
                        --copts "$(TARGET_CFLAGS)" \
                        linux-2.2 \
@@ -50,6 +53,9 @@ define Build/Configure
 endef
 
 define Build/Compile
+       UNAME_S=Linux \
+       UNAME_M=$(ARCH) \
+       UNAME_R=2.4.34 \
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
@@ -58,12 +64,12 @@ endef
 
        
 define Package/dhcp-relay/install
-       install -d -m0755 $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/usr/sbin
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/dhcrelay $(1)/usr/sbin/
 endef
 
 define Package/dhcp-server/install
-       install -d -m0755 $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/usr/sbin
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/dhcpd $(1)/usr/sbin/
 endef