[net] Telephony: Moved baresip to telephony submenu.
[openwrt/svn-archive/archive.git] / net / dhcpcd / Makefile
index 2be935ed95193efc60b388afe9dbf122a7e2b8d3..53f6aa0cf82422287a80d902caf9ea9c4134c138 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -14,7 +14,8 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://download.berlios.de/dhcpcd/
 PKG_MD5SUM:=e9100e53f64ca1f9fb0d392c3a623738
-PKG_CAT:=bzcat
+
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -22,7 +23,7 @@ define Package/dhcpcd
   SECTION:=net
   CATEGORY:=Network
   TITLE:=DHCP client for automatically configuring IPv4 networking
-  URL:=http://dhcpcd.berlios.de/
+  URL:=http://roy.marples.name/projects/dhcpcd
 endef
 
 define Package/dhcpcd/description
@@ -30,14 +31,6 @@ define Package/dhcpcd/description
        IP address changes.
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               CC="$(TARGET_CC)" \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               all install
-endef
-
 define Package/dhcpcd/install
        $(INSTALL_DIR) $(1)/sbin
        $(CP) $(PKG_INSTALL_DIR)/sbin/* $(1)/sbin/