[packages] ddns-scripts: use /proc/uptime as time reference, this makes it immune...
[openwrt/svn-archive/archive.git] / net / dircproxy / Makefile
index 74047d72d89e2a31a3516dab081b83eca5c4f5db..68966370680fd9d490140171c3f24c76a8558501 100644 (file)
@@ -4,42 +4,34 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dircproxy
-PKG_VERSION:=1.2.0-beta2
+PKG_VERSION:=1.2.0-RC1
 PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz
-PKG_SOURCE_URL:=http://dircproxy.securiweb.net/pub/1.2/
-PKG_MD5SUM:=850443437f709276ff21a173bbf98456
-PKG_CAT:=bzcat
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://dircproxy.googlecode.com/files/
+PKG_MD5SUM:=4fe2e82619c7b575599bfb236adbd872
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/dircproxy
+  SUBMENU:=Instant Messaging
   SECTION:=net
   CATEGORY:=Network
   TITLE:=An IRC proxy server
-  URL:=http://dircproxy.securiweb.net/
+  URL:=http://dircproxy.googlecode.com/
 endef
 
 # uses Build/Configure/Default
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
 define Package/dircproxy/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/dircproxy{,-crypt} $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/dircproxy{,-crypt} $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,dircproxy))